WordPress.org

Ready to get started?Download WordPress

Forums

Yoko
unable to upload images (10 posts)

  1. rphofer
    Member
    Posted 2 years ago #

    I'm having trouble uploading content to the media library. I've tried inputting the file path manually under settings. The media library doesn't even show the files when I upload them via ftp and I know they are in the correct place. One possible problem: this is a WP blog on a subdomain. Any ideas?

    http://wordpress.org/extend/themes/yoko/

  2. rphofer
    Member
    Posted 2 years ago #

    I keep getting Internal Server Error

  3. zartgesotten
    Member
    Posted 2 years ago #

    You shouldn't upload via ftp. WordPress won't find the files automatically. It will only "know" files it has put there themselves.

    Internal Server Error might happen because you ran out of php memory or the image is too large. Try a very small image to rule that out.

    Good luck
    Anja

  4. rphofer
    Member
    Posted 2 years ago #

    I tried a very small image. I think WP should recognize jpg files in the wp-content/uploads folder, whether put there through the WP uploader, or an ftp client. Somehow the theme is not accessing the uploads folder and I think this is because I am using a subdomain to host my second blog.

  5. zartgesotten
    Member
    Posted 2 years ago #

    Hi !
    Did you check the folder options in Options > Media ? Is the right path in there?
    And did you give writing permissions to your wp-content/uploads folder?

    Subdomain shouldn't be a problem.

  6. rphofer
    Member
    Posted 2 years ago #

    I guess it's not the theme because I have the same problem with other themes. I can't upload anything into the uploads folder. I've tried specifying the path but I must not be getting it right.

  7. rphofer
    Member
    Posted 2 years ago #

    Now I'm just trying to figure out how to get my original blog to work. It used to upload fine, but now I get an Inter Server Error. I wonder if something changed in the new WP? I tried changing the file permissions to granting everything in the wp-admin folder, but then nothing seemed to work.

  8. rphofer
    Member
    Posted 2 years ago #

    I guess the uploads folder automatically has the permissions set. Seems to be because of the file size I was trying! But how can I get a high-quality header image if it limits my files so strictly?

  9. zartgesotten
    Member
    Posted 2 years ago #

    I don't get it... does it work now or not?
    Upload file sizes are defined in Options > Media, there's a maximum attachment size. Make sure the value there is ok.

    Also max file size is defined in web server settings. I guess you won't have any power over that.

    Hard to say what's wrong from here.
    But it's probably just a setting thing.

  10. rphofer
    Member
    Posted 2 years ago #

    thanks for the help! At this point it seems to be some kind of issue with file size.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic