WordPress.org

Ready to get started?Download WordPress

Forums

Wordstrap
[resolved] fatal error (8 posts)

  1. gottaloveit
    Member
    Posted 1 year ago #

    got this fatal error after installing theme

    Parse error: syntax error, unexpected T_FUNCTION in .... /wp-content/themes/wordstrap/functions.php on line 189

    great, now my blog dont load

    http://wordpress.org/extend/themes/wordstrap/

  2. keesiemeijer
    moderator
    Posted 1 year ago #

    Remove the wordstrap theme by using FTP or whatever file management application your host provides.

  3. gottaloveit
    Member
    Posted 1 year ago #

    yea i know. fix the bug though

  4. keesiemeijer
    moderator
    Posted 1 year ago #

    I installed the theme on my test site and didn't have any errors. What version of PHP is your host using? Contact support if you don't know.
    Or check the version with this in a theme template file:

    <?php
    // prints e.g. 'Current PHP version: 4.1.1'
    echo 'Current PHP version: ' . phpversion();
    ?>

    It has to be 5.3.0 or higher for this theme to work.

  5. gottaloveit
    Member
    Posted 1 year ago #

    oh so forget the wordpress.org requirements of 5.2.4 ? that should be mentioned in your description maybe?

    also, when did the add_filter function support anonymous functions as the callback? ( Add hierarchy support to wp_nav_menu )

    my php version: Current PHP version: 5.4.5

    funny though, when I commented out that add_filter on 189, works great. i would check that again.

  6. keesiemeijer
    moderator
    Posted 1 year ago #

    that should be mentioned in your description maybe?

    I'm not the plugin author.

  7. Aritz Olabarrieta
    Member
    Theme Author

    Posted 1 year ago #

    Hi gottaloveit. You are right and I must mention you need PHP 5.4.5 in the description of the theme. Anyway, I will try to make the nav_menu hierarchy work without having to use anonymous functions, and this way the need of PHP 5.4.5 version will be gone. If you have commented out that filter in your site, probably the menus which have children will not display properly, that's the reason why I wrote that lines of code. This issue will be fixed in the next version of the theme.

  8. Aritz Olabarrieta
    Member
    Theme Author

    Posted 1 year ago #

    Issue has been fixed in theme version 1.7.3.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags