WordPress.org

Ready to get started?Download WordPress

Forums

Weaver II
Removing the column on the right (5 posts)

  1. justinasia
    Member
    Posted 2 years ago #

    I am totally new to this but have been unable to find out how, so help much appreciated!

    With this theme, there is a column on the right saying:

    "Recent Posts

    Hello world!

    Recent Comments"

    and so on.
    How do I get rid of that? I just want a simple website. No posts, no comment section (I managed to remove that by de-selecting "Allow comments".

    I also cannot find how to add pictures to the page. With google sites there was a simple button for adding pictures. How to do it here?

    Also, since I just need a single column, with my own writing, pictures and graphs (no blog) do you think this is still the right theme for me or am I better off changing?

    I am so new to this and really appreciate your help. It means a lot.

    Thank you.

    http://wordpress.org/extend/themes/weaver-ii/

  2. Chris Marslender
    Member
    Posted 2 years ago #

    Do you have wordpress set up to show a static front page? (Off by default)

    In the administration area, click on pages and add a new page. Once you are done with that, go to settings, then reading. One of the options is 'Front page displays' - set that to A static page, and then under front page, choose the page you just created. You don't need to worry about the posts page if you do not intend to use posts.

  3. justinasia
    Member
    Posted 2 years ago #

    Hi cmmarslender,
    I just did what you said, made another page (one for which I turned comments OFF) the static page. So there is that one I made, and the two remaining are another I made, and the sample page. But it did not seem to change anything. There is still the comments box on those two.

    But more importantly, still all of those links on the right, like I mentioned:
    "Recent Posts

    Hello world!

    Recent Comments"

    and so on. Since I am not making a blog, that entire section on the right is irrelevant for my site. Am I just using the wrong theme, or is there an easy way to turn that stuff off? I was expecting to be able to just click on it and select delete or something.

    Help much appreciated.

  4. justinasia
    Member
    Posted 2 years ago #

    OK I found a part solution, so for those also searching:

    If you go to "pages", then "all pages", you can see each page and by moving the cursor over them, click on "quick edit". There you can de-select "allow comments". You have to do that one by one for each page.

    I am surprised there is not a way to do it globally.

    Also found how to turn off the links and stuff on the right:
    Go to a page and click "edit".
    On "Weaver II Options for this page" select "Hide Primary (top) Area".
    ---------------

    What I would like to know is, can these two things not be done globally? Or can we not create our own template, so we don't have to do these things for each new page one by one?

  5. RoamFree
    Member
    Posted 2 years ago #

    That column on the right is the sidebar area, which is showing Widgets. You're asking about the Weaver II theme, which offers a control for that.

    Go to Appearances > Weaver II Admin > Main Options > Layout.
    (On the Dashboard, look for "Appearances". Some of the above options are on tabs.)

    In "Sidebar Layout", the first item is "Blog, Post, Page Default". Use the pulldown menu to select "No sidebars, one column content". That selects no sidebars.

    Click "Save Settings".

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags