WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme Weaver - Gallery post view problem (4 posts)

  1. boldt
    Member
    Posted 3 years ago #

    I am trying to create a multi-language site, using WP3.1 qLanguage and I have ticked "Display full posts"

    I am using the standard gallery system

    But something goes wrong!
    look here: waste.325.dk (Home)
    and here: waste.325.dk/?p=100 (the actual post)

    How do I get the appearance of /?p=100 to be on Home ?

  2. wpweaver
    Member
    Posted 3 years ago #

    I don't think this is a theme issue.

    Please try temporarily switching to Twenty Ten and see if the problem persists. If it does, then the problem is not a Weaver issue.

  3. boldt
    Member
    Posted 3 years ago #

    Yes ... and No

    Just tried to change to twenty ten and then all the "CSS" stuff disappeared.

    but still the post is identified as a gallery with a sentence:
    "This gallery contains 7 photos." instead of just showing the entire post as I want

  4. boldt
    Member
    Posted 3 years ago #

    it is the gallery.php that creates the problems, so I have changed the content to:
    <?php
    /**
    * Template for displaying gallery excerpt
    */
    ?>
    <div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    <h2 class="entry-title"><?php weaver_post_title(); ?></h2>
    <?php weaver_posted_on(); ?>
    <div class="entry-content">

    <?php the_content(); ?>
    </div><!-- .entry-content -->
    <?php weaver_posted_in(); ?>
    </div><!-- #post-## -->

    Which serves my purpose!

Topic Closed

This topic has been closed to new replies.

About this Topic