WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Twelve
Language errors (3 posts)

  1. lukuliike
    Member
    Posted 1 year ago #

    I'm using the Finnish WordPress 3.4.2 but it seems that the twentytwelve.pot file in the languages folder overrides the WP in some places. I changed some of the lines in the pot-file using Notepad as the file wouldn't open in PowerPoint. No use. See the English lines in my otherwise Finnish site, what should I do?

    http://www.gaudeamus.fi/suomalaisetjahistoria/

    (Never minf the poll, that's another issue altogether...)

    http://wordpress.org/extend/themes/twentytwelve/

  2. The content of the POT file is the basis for translations in general. Changes within that file do not alter the front end display. See the Translating WordPress Codex page for more information on that.

    It seems like the Theme is just not completely translated yet. It would be awesome if you could help out with translating Twenty Twelve into Finnish!

    Konstantin

  3. aguseo
    Member
    Posted 1 year ago #

    @lukuliike
    You need to use poEdit or something similar to edit the .po/.pot language file. Then save the file like fi_FI.po (I think that's for Finnish, right?) and then it will generate the required .mo file.
    Then copy this into the language folder under twentytwelve.

    You might hit an error when saving. This is because the handling plurals is not set up in the .pot file.
    In poEdit go to Catalogue, then Settings.
    In the field 'plural forms' paste this:
    nplurals=2; plural=n != 1;

    After this saving should be fine.
    There is one line requiring plurals, starts with:
    "One thought on..."

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic