WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Eleven
Latest update broken (3 posts)

  1. Cjcornell2
    Member
    Posted 3 years ago #

    What the heck?

    I was working on a simple WP.org site for a client using this twentyeleven theme as a basic starting point. While I was working on it, there was notifcation of an update. No matter - I updated since I was not modifying any css etc ;... and bam. havoc. I have the site set up such that the front (home page) was NOT the blog posts page ... it is still explicitly set up such that a static (regular) page is the home page. it is also set up in the menu setup that the blog posts page is not represented in the navigation either. But no matter what I do now - the blog posts page is not only the home page - but when I click on the navigation bar for the first (leftmost) selection aptly named after a PAGE - wordpress (this theme) displays the blog posts page.

    The bug can't be any more obvious: 5 seconds ago my navigation was working as expected and the home page was a specific "page" (not posts). Updated TwentyEleven and now the faulty behavior - despite the settings (in settings->reading).

    Did anyone test this? or is this what trusting users are for when we click "update". Please fix - I'd rather not hack away at CSS or PHP to get this working when it should already be working.

    Thanks!

    http://wordpress.org/extend/themes/twentyeleven/

  2. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Static Page as front page works just fine for me with Twenty Eleven 1.2...

    Can you provide any additional information?

  3. Cjcornell2
    Member
    Posted 3 years ago #

    Yes, I just figured it out - after 2 hours ...
    turns out that I have html in the main page (the static page) ...
    ALL the html was, was comments eg

    <!-- tomorrow, experiment with the photo carousel etc
    plus some commented out <div> tags
    -->

    in the prior version of twentyeleven, this truly was handled as a comment. as soon as I updated, it caused the unpredictable behavior I wrote about above.

    Thanks for jumping in so quickly to try to help

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic