WordPress.org

Ready to get started?Download WordPress

Forums

Suffusion
[resolved] RSS feeds not working (8 posts)

  1. gsvalentine
    Member
    Posted 2 years ago #

    For some reason the RSS feeds are not working. When I go to http://www.gordon-valentine.com/feed/ with firefox 13, I just get a blank page.

    http://wordpress.org/extend/themes/suffusion/

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  3. Sayontan Sinha
    Member
    Theme Author

    Posted 2 years ago #

    Yes, sorry about that. There is a bug in this version. To fix it, you can go to wp-content/themes/suffusion/functions/filters.php. Near the end of this file you will see this line (in the function suffusion_modify_title):

    if ((isset($suffusion_list_layout) && $suffusion_list_layout) || (isset($suffusion_mosaic_layout) && $suffusion_mosaic_layout)) {
    		return $original_title;
    	}

    Change it to:

    if ((isset($suffusion_list_layout) && $suffusion_list_layout) || (isset($suffusion_mosaic_layout) && $suffusion_mosaic_layout) || is_feed()) {
    		return $original_title;
    	}

    You might have to wait for a bit for your changes to show up, depending on the frequency with which your feed is updated.

    I will release a patch for this tonight.

  4. gsvalentine
    Member
    Posted 2 years ago #

    Thanks very much. All working now :).

  5. Laudiceia A. R.
    Member
    Posted 1 year ago #

    Hi, I checked the line but still does not work.

    When I enter the feed's link wordpress is saving looping.
    When I run website it loses widget.

  6. Sayontan Sinha
    Member
    Theme Author

    Posted 1 year ago #

    Hi, I checked the line but still does not work.

    I am surprised you are having to change the line at all. I had fixed it and released the patch at the time of my previous post here, so if things are not working for you, it is probably because of a non-Suffusion reason.

  7. Laudiceia A. R.
    Member
    Posted 1 year ago #

    Oh my god! okay. so I'll try to find the problem.

  8. Laudiceia A. R.
    Member
    Posted 1 year ago #

    No way. I insert my feed and shows that he is saved, but when I leave the widgets page and return it is not there.

    A feed can be placed anywhere on the site? It has a specific location?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags