WordPress.org

Ready to get started?Download WordPress

Forums

Simple Catch
[resolved] Logo Sizing (11 posts)

  1. Haaps
    Member
    Posted 2 years ago #

    Hi there,
    Is there a way to define the size of the logo I upload rather than having the blog automatically make it so small? I searched the code but couldn't find anything.

    Thanks,
    Kyle

    http://wordpress.org/extend/themes/simple-catch/

  2. Digest WP
    Member
    Posted 2 years ago #

    Hello,

    In your WordPress dashboard you can go to Settings>Media and then you can change the upload sizes.

  3. Haaps
    Member
    Posted 2 years ago #

    Unfortunately that doesn't work. The logo is being resized automatically to a max width and height. It's some sort of custom feature of the template I'm using. The sizes I select within the media controls have no effect.

    Thanks

  4. Digest WP
    Member
    Posted 2 years ago #

    Next thing would be to edit the header.php and add the logo manually to overide the theme settings. Or check the functions file to edit the size.

    Jay S

  5. radhika
    Member
    Posted 2 years ago #

    Firstly you have to commented the function 'simplecatch_headerdetails();' which define in header.php file of your theme . After this you can use this code in 'header.php' file to define the size of the logo. This code will be used after this class 'layout-978':

    <div class="logo_wrap">
                        <span>
                                <a href="<?php echo home_url( '/' ); ?>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a>
                        </span>
                    </div>

    And you also add the class in style.css of your theme :

    /*add the logo class*/

    .logo_wrap{
    margin: 8px 0 15px 0;
    float: left;
    font-size: 30px;
    line-height: 36px;
    width: 169px;
    height: 78px;
    }
    .logo_wrap a {
    color: #000;
    font-weight: bold;
    text-decoration: none;
    display: block;
    width: 90px;
    height: 89px;
    text-indent: -999em;
    background: url(images/logo.png) no-repeat;
    }

  6. radhika
    Member
    Posted 2 years ago #

    Sorry i was wrong. you have to change only in style.css of your theme.
    Add in style.css:

    h1#site-title a img {
    	max-height: 190px;  //add the max-height a/c to you
    }
  7. Haaps
    Member
    Posted 2 years ago #

    The last option you wrote doesn't seem to work either. Perhaps your previous post was correct?

  8. Andrew
    Forum Moderator
    Posted 2 years ago #

    Don't make changes to the stylesheets of your theme, as once the theme is updated, your changes will be lost.

    Before you add styles, make sure you do so in either of the following:
    A Child Theme - http://codex.wordpress.org/Child_Themes
    A Custom Style plugin - http://wordpress.org/extend/plugins/custom-style/

  9. Sakin Shrestha
    Member
    Theme Author

    Posted 2 years ago #

    Hi Andrew,

    There is Custom CSS Box in the Theme Option where you can add in few simple css and the best option is always child theme.

    Regards,
    Sakin

  10. deflepp
    Member
    Posted 1 year ago #

    hey,

    i have the same problem, wp automatically resizes my uploaded logo.

    Here is the link to my homepage : http://philippe-eicher.de/wordpress/

    Can you help my with a solution that works, which parameters do i have to edit / add in the style.css of the theme ?

    thanks in advance

  11. Sakin Shrestha
    Member
    Theme Author

    Posted 1 year ago #

    @deflepp: You can upload logo from Logo option to any size you like.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic