WordPress.org

Ready to get started?Download WordPress

Forums

Scherzo
[resolved] CSS Inserts section available? (12 posts)

  1. Jojo
    Member
    Posted 2 years ago #

    I wondered if someone could help me with something.

    I am using the Scherzo theme and have installed a plugin called All-In-One Event Calendar and as part of the layout editing of this plugin I need to make some changes to the CSS Inserts section of my theme. However, I can't seem to find the CSS inserts option anywhere.

    Having read through the notes on the creator's blog I then assumed this meant I needed to create a child theme which I did and included the necessary amendments but it hasn't made any difference. I wondered if anyone can point me in the right direction. Sorry I'm a bit of a novice when it comes to WordPress!!! Any help would be very greatly appreciated.

    Many thanks

    Jo

    http://wordpress.org/extend/themes/scherzo/

  2. josjo
    Member
    Posted 2 years ago #

    How does the css file for the sub theme look? Do you include the css file from the parent theme?

  3. Jojo
    Member
    Posted 2 years ago #

    for the child theme?
    Here's the css from the new child theme i've made:

    [CSS moderated as per the Forum Rules. Please just post a link to your site.]

    Now I read back through the code I wonder if this line:
    '@import url("../scherzo/style.css");'
    should refer to the css file for the calendar plugin rather than the Scherzo style sheet??

    Thanks

    Jo

  4. Jojo
    Member
    Posted 2 years ago #

    apologies didnt realise how i was supposed to include code. Please view code here
    http://pastebin.com/Dq39zuSY
    Thanks

  5. josjo
    Member
    Posted 2 years ago #

    The child theme looks good. The problem is your css rules gets overridden by the calendar plugin. There are ways to tell WordPress which order it should load the css files, but that would need some changes in the theme.

    Your options are:

    1. Add !important after the property (i.e. overflow: inherit !important;). This only works if the plugin css doesn't do the same.

    2. Make changes directly to the plugin css (all-in-one-event-calendar/css/calendar.css). Don't forget to migrate your changes if you update to a newer version.

    3. Rewrite the theme to use wp_register_style/wp_enqueue_style with dependencies. All-in-One Event Calendar does this so it should work.

  6. Jojo
    Member
    Posted 2 years ago #

    Thanks so much for this.

    I did try to make the amends directly in the plugin css as I assumed this would be the easiest option, however, I can't seem to allow myself the correct permissions to upload it with the amendments to the code. I have tried changing the document and the folder to 777 temporarily but it just tells me I don't have permission.

    it is only this one line that needs changing twice:
    'white-space: normal;'

    Failing this I will try adding !important as you suggest to see if this fixes it.

    Thank you so much

  7. Jojo
    Member
    Posted 2 years ago #

    Unfortunately I've checked the calendar code and it does use !important so now I'm back to having to try to amend the actual calendar.css file but can't seem to change the permissions on it. I wonder if this is a Mac thing and I should try changing permissions on a PC.
    Has anyone else had experience of this or successfully been able to change permissions?
    Thanks

  8. josjo
    Member
    Posted 2 years ago #

    Is this a local install or installed on a web server at some hosting company? If it's hosted and you have access to cPanel you may be able to fix the permissions from there.

  9. Jojo
    Member
    Posted 2 years ago #

    It's hosted on a web server that uses Parallels Plesk Panel. I've tried logging in to Plesk as well to amend the permissions but still it won't let me.

    Again, I wonder if this is a Mac thing, I will try via a Windows PC I think and if that still doesn't work I may have to admit defeat and give up :(

  10. Jojo
    Member
    Posted 2 years ago #

    This is really frustrating me now :(

    I have tried to do it on a Windows PC and still can't change the permissions of the original calendar.css file, it just gives a warning saying I don't have permission to change the permissions.

    So I tried adding !important behind the two lines I had changed in my new/style.css child theme so they became 'white-space: normal !important;' and still no changes :(

    Please, please, please any other ideas??

  11. josjo
    Member
    Posted 2 years ago #

    It's hard to do anything if you can't change the files on the server. I would like to help you but that would mean I'd have get access through Plesk or FTP.

  12. Jojo
    Member
    Posted 2 years ago #

    All sorted now, thanks for your help josjo.

    I've just discovered that there's an editor section within plugins that allowed me to edit the calendar.css file in there!! D'oh

    All up and working now though

    thank you so much for your help

    Jo

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic