WordPress.org

Ready to get started?Download WordPress

Forums

Responsive
[resolved] [closed] Why so slow? (22 posts)

  1. babyatom
    Member
    Posted 1 year ago #

    Hi,
    'Responsive' is a lovely theme but for some reason it's making my website very slow! Can anyone help me identify the cause please?
    http://www.jollyit.co.uk

    Bit of background:
    I have several sites with my host, using different themes, and they're fine.
    If I switch my website to another theme it's fine.
    Switching off the plugins makes no difference.

    Help!

    http://wordpress.org/extend/themes/responsive/

  2. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Hi,

    I am going to say a temporary glitch with your host. Responsive if anything it should be faster than most of the Themes, when Responsive was built I made sure that there's no bloating, no multiple JS or anything that would slow the site down.

    Just tested to see if there's anything and the page loads in 1.04s that's very fast. Please see performance report.

    Thanks,
    Emil

  3. sassyfrog
    Member
    Posted 1 year ago #

    I agree the theme is really fast! However, it's like the header and background get reloaded on each page, which ends up "blinking" when browsing the site. This does not happen when using Firefox because the page is only displayed when all elements are loaded and the navigation is fast and smooth. But Responsive is "blinking" on Chrome and Safari (fast, but not "smooth"). Any clue on how to minimize this effect? Even with a very lean background and header, the "flashing" occurs.
    Thanks for this wonderful theme!

  4. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Hi,

    What's the URL please?

    There's no blinking from my end, however please note that not all browsers will behave the same and also this can vary on the hosting (server) as well.

    Thanks,
    Emil

  5. sassyfrog
    Member
    Posted 1 year ago #

    http://www.lostindots.com/stage
    This is a stage URL for a site I'm building. I set a temporary user for you to check it out: you may login as "guest". Password is "demo"
    Thanks for taking time for this! I appreciate!

  6. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Please don't share login credentials publicly and feel free "revoke" the guest ;)

    All right, the reason behind is quite simple, your background is 1000 x 366 which happens to be the largest graphic on your site (2,844 bytes) and that's why it's loading last. What I can recommend is to compress the image with tools like "ImageOptim" and/or any other alternatives.

    Thanks,
    Emil

  7. sassyfrog
    Member
    Posted 1 year ago #

    I revoked the temporary user. Thanks for the quick reply! I'll try with a smaller, tiled background image.
    Thanks again for your theme!

  8. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Not a problem :)

    Please rate the Theme if you already didn't.

    Thanks,
    Emil

  9. sassyfrog
    Member
    Posted 1 year ago #

    Hi there! I made the change in my header and background and it ends up the size does not matter. No matter how light and small, the minute I set up a custom header and background, you can see it loading (fast but annoying flashing when loading a new page). This does not occur with the default header provided with the theme. When I looked at the function.php file, it seems that there's a lot of instructions to adjust to a custom header. I guess this is what slows it down? Should I customize the function file and hard code my custom header as the default?

  10. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Please see this link.

    If you're using newer version of Responsive, no need to edit any files, Theme supports flex images and you can use any size you please :)

    Thanks,
    Emil

  11. sassyfrog
    Member
    Posted 1 year ago #

    Thanks Emil. My mistake.

  12. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    It's all good :)

    Emil

  13. sassyfrog
    Member
    Posted 1 year ago #

    Just tested it again with just the naked theme, a 7KB background image and 1KB header, and a plain fresh wp install. It works fine.

  14. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Awesome. I re-edited this post :)

  15. sassyfrog
    Member
    Posted 1 year ago #

    Yep. I realized as I wanted to show you the problem that the "jump" was due to the "Private WP" plugin (for a password protected blog). Deactivating the login is solving the problem.
    ...Now, I have to find a better way to lock out unwanted visitors ;-)

  16. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    What kind of unwanted visitors, you mean people who SPAM or?

  17. sassyfrog
    Member
    Posted 1 year ago #

    No. I really need subscribers to log in to access this site. So I implemented a plugin for that. But the plugin must be checking if I'm logged in at each page after that... so it's slowing down everything.

  18. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    You can do this:

    create functions.php within your Child Theme and add something like this

    <?php
    function password_protected_site() {
        if ( !is_user_logged_in() ) {
            auth_redirect();
        }
    }
    
    add_action ('template_redirect', 'password_protected_site');
    ?>

    This will work without a plugin and it relies on WP Login only and it's for registered members only. Now what's needed here is to open your registrations and that's pretty much it.

    You can also style your login any way you need with: http://wordpress.org/extend/plugins/erident-custom-login-and-dashboard/

    Emil

  19. sassyfrog
    Member
    Posted 1 year ago #

    Exactly what I needed! Thanks so much!
    I'm definitely becoming a fan of this theme... and assistance!
    Thanks for your time on my "user errors" ;-)

  20. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    My pleasure :)

    Emil

  21. leew007
    Member
    Posted 1 year ago #

    Hi, I am just looking to see if anyone else thinks my site is slow on mobile devices, it seems to be reasonable on desktops but on my mobile it is like 7-10 sec, if anyone had any suggestions I'd appriciate it...

    my site it http://www.dmdatasolutions.co.uk

    I'm also using WP super cache, WP Minify, ewww image optimizer

    thanks

    Lee

  22. esmi
    Forum Moderator
    Posted 1 year ago #

    If you want your site reviewed, please post in http://wordpress.org/support/forum/your-wordpress

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags