WordPress.org

Ready to get started?Download WordPress

Forums

Responsive
[resolved] upload logo transparent png image gets jpg'ified (10 posts)

  1. maxemil
    Member
    Posted 2 years ago #

    Problem: When uploading a header image, its saved in jpg format.
    jpeg dosent have transparency.

    Wish: Trust the admin upload, and let the original transparent png be used.

    Workaround: screengrab current background and use as solid background instead of transparency.

    http://wordpress.org/extend/themes/responsive/

  2. Emil Uzelac
    Theme Review Admin
    Posted 2 years ago #

    maxemil,

    First of all thank you for using Responsive Theme, you rock!

    Ah the logo situation, actually there's no issues with WordPress logo uploader, when I said WordPress and not the Theme itself is because we're using custom header feature by WordPress for our logo.

    All right, when saving a logo, or any other PNG image make sure that the its saved correctly:

    • PNG-24
    • Transparency
    • No Matte

    If your PNG image isn't saved like that, you'll have the fuzzy border around and poor image quality.

    Also, you mentioned JPEG, no it doesn't have to be JPEG, you can use PNG, GIF or anything else you think that it might work.

    This is coming from the guy who started working on Photoshop much before I did in WordPress.

    By the way, if you have any questions, please visit our free and dedicated support forum.

    Best of luck and thank you so much for using Responsive Theme!

    Emil

  3. ukristen
    Member
    Posted 2 years ago #

    I have the same issue. I am trying to upload a 872x37 px graphic in png format and during the upload the graphic is being converted to jpg and cropped to 300x100 pixels.

  4. Emil Uzelac
    Theme Review Admin
    Posted 2 years ago #

    Hi,

    @ukristen you and @maxemil have different things and none of them are Theme issue. WordPress custom header does crop anything above 300x100. Please see:

    Please post your further questions on our support forum if you can http://themeid.com/forum

    P.S. It's only one me and it's hard to be at two places at once. Theme is 100% and my help too!

    Cheers,
    Emil

  5. ukristen
    Member
    Posted 2 years ago #

    Thanks for the quick response! I will move over to your forum.

  6. Emil Uzelac
    Theme Review Admin
    Posted 2 years ago #

    Thank you for using Responsive and we welcome you to our forums.

    Emil

  7. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Just going over the older posts, please let me know if you guys need more help and also quick reminder that our dedicated forum is always open and free as well.

    Thanks,
    Emil

  8. seven7d
    Member
    Posted 1 year ago #

    Hello,I've been searching for a while but can't find a solution so thought I'll finally ask: There doesn't appear to be an upload option for the customise logo when I try to customise this in Responsive.

    I go to appearance>themes>theme options>logo upload.

    The only options I have is to delete the existing logo or reinstate it. Feel silly as there's prob something obvious I'm missing here?

  9. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Hi,

    Don't worry about it, we're here to help, although this topic was resolved 10 months ago and if mods don't mind I am ready to help.

    Anyways, this is what should be in: http://i.imgur.com/SoUVJx8.png and you can access this from Appearance > Header. If you don't see the upload it could be that you're not using the admin privileges, which is less likely because you would not even see the option to this page, but with some custom roles it might be the case.

    Also check your WP install, make sure that all is running the way it should, check if you have content caching plugin and if so clean the cache and check again. Lastly go over your plugins etc.

    Thanks,
    Emil

  10. seven7d
    Member
    Posted 1 year ago #

    Thanks for your help. I went through the plug-ins and had a plug in "delete custom header" or alike. Deleted it and it now works (as you would expect).

    I'll have to be a little more careful installing plug-ins! Can't recall that one.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags