WordPress.org

Ready to get started?Download WordPress

Forums

Theme related image not showing only in Firefox (4 posts)

  1. dharma.arte
    Member
    Posted 3 years ago #

    Hi,

    I'm using W3 Total Cache 0.9.2.3 and have setup a self-hosted CDN using another domain in a shared hosting.

    The header image on our site, defined in the theme's style.css file, shows in IE9, Opera, Safari, Chrome -- but doesn't show in Firefox and SeaMonkey if "Host Theme Files" is selected in W3TC. I've unselected this option because only this image, defined by the theme, was not showing -- and then the image shows correctly also in Firefox and SeaMonkey.

    Any ideas?

  2. Frederick Townes
    Member
    Posted 3 years ago #

    Are you still having this issue? Took a look at your site and with all of the optimizations running, it's difficult to analyze.

  3. dharma.arte
    Member
    Posted 3 years ago #

    Hi, thanks for replying.

    No, I'm not. After the issue, I've deselected the option "Host Theme Files", and haven't made more attempts. On that occasion, that behavior was clear.

    I have no idea of the reasons... A few days ago we've started using a true CDN, and I've edited our style.css file so that the header message is hosted also on our CDN (because the image was manually defined in the style file, it was in one server, and the rest was in another one). I've also checked again the option for hosting the theme files. And it's working.

    Of course this was done with a try and error approach.

    Right now we only aren't able to use the minify feature in W3TC, as it corrupts the design, and makes the menu unusable. We're using WP-Minify, which for some reason does work (we've only had to introduce an exception for the menu). If you can suggest any workaround, it'll be great. We'd like to have the minified files in the CDN, but this is not possible (as far as I know) using WP-Minify.

    Thanks again!

  4. Frederick Townes
    Member
    Posted 2 years ago #

    Can you submit a bug submission form from the support tab of the plugin?

Topic Closed

This topic has been closed to new replies.

About this Topic