WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme preview not working (7 posts)

  1. rockylaber
    Member
    Posted 4 years ago #

    I have taken an existing theme, modified and renamed it - the mods are mostly in the color, e.g., I've resaved some of the graphics so they're blue instead of gray. I've also done a little tweaking to the css. I've been careful to edit the css file to include updated info for Theme Name, Description, Version, Author, Author URI, and Tags. From the Manage Themes page in the Dashboard, I can see the screenshot.png, description, etc., and I CAN activate the theme, but it doesn't render a preview the way all my other themes do, just a blank page with no content or wp elements. The original theme I duplicated displays perfectly.
    Does anyone know how to rectify this?
    Thank you!

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Try checking your basic template files - header.php, index.php,sidebar.php and footer.php. A syntax error in one of those files could cause the symptoms you describe.

  3. rockylaber
    Member
    Posted 4 years ago #

    esmi, thanks for the suggestion. I looked at the basic template files and can't see anything out of order. The original theme that I modified and renamed DOES show a preview. I simply duplicated the entire theme folder, then edited the css file to reflect the change in the theme's name. Nowhere did the original theme did the basic template files make direct reference to its name (I first thought that could cause the problem). So I'm still looking for an answer or guidance. Thanks

  4. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Did you edit any files other than style.css? Have you validated your customised style.css? A block of seriously whacked out code in that CSS file could, in theory, knock the preview out. Did you rename the new theme folder without using any spaces or other weird characters?

  5. rockylaber
    Member
    Posted 4 years ago #

    the css file of the duplicate is identical to the original with the exception of:
    Theme Name
    Description
    Version
    Author
    Author URI
    Tags
    I also changed a couple of background colors, but nothing significant. I'll check on the validation part next
    thanks!

  6. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    If you're still having problems, send a copy of the theme to esmi at quirm dot net and I'll see if it runs in one of my development installs.

  7. rockylaber
    Member
    Posted 4 years ago #

    OY! I had an illegal character in the folder name. Thanks for the help

Topic Closed

This topic has been closed to new replies.

About this Topic