WordPress.org

Ready to get started?Download WordPress

Forums

Theme preview box is gray, preview not working (17 posts)

  1. caNative
    Member
    Posted 7 years ago #

    I have two domains. The first has an installation using Bluehosts Fantastico and is working perfectly. The second domain has a fresh manual install in my bluehost acct, for which I setup a second WP db because I observed some weird behavior during a Fantastico install, so I removed the fantastic install on domain 2 and did a manual install. I figured 2 WP db's were better than a shared.

    domain2 = http://www.sftechparties.com

    I was successful in the manual install on domain2, and WP seems to fully function, but any theme I choose, including the default, does not render fully on my website. It's as if some files are not loading properly.

    Also, the Theme names show up in Presentation, and I can change Themes successfully, but I only see a gray box in Presentation for each Theme preview. No preview is available and I suspect this is related to the way that the Theme partially renders on http://www.sftechparties.com

    I'm trying to figure out if this is a problem related to using two WP db's? I don't think this is a config problem is it?

    This is what the current Theme should look like http://www.onehertz.com/portfolio/wordpress/mandigo/

    I just discovered that the formatting buttons are also not showing up when I try to write a post.

    This weird behavior is the same for both the Fantastico and the Manual install.

  2. Glenn Ansley
    Member
    Posted 7 years ago #

    I've had problems like this before when my ftp connection/program is flakey. Try ftping the admin folder again. If that doesn't work, try the includes.

  3. caNative
    Member
    Posted 7 years ago #

    Thanks for the reply blepoxp, unfortunately that didn't work.

    Interestingly when I refresh while on the Write Post page, the formatting button images start to render, then they dissapear. It's as if something is preventing them from showing properly.

  4. Glenn Ansley
    Member
    Posted 7 years ago #

    I know this is a basic question, but is use visual editor checked in your user profile?

    Also, not to beat a dead horse, but there have been times that I had to try uploading several times before my ftp program worked correctly. Try uploading the wp-admin/themes.php file by itself.

  5. caNative
    Member
    Posted 7 years ago #

    Hmm, I unchecked the "use visual editor" box and my buttons are there now.

    However the problem with the Gray Preview Theme boxes (as in "not working") is still there. And http://www.sftechparties.com still only has half the Theme rendered.

    I also tried uploading themes.php several times...

    Any other ideas to share?

  6. Glenn Ansley
    Member
    Posted 7 years ago #

    Do you have any special plugins installed. Try deactivating them one at a time.

  7. caNative
    Member
    Posted 7 years ago #

    It's a fresh install.

    The only thing I changed for the install was config.php and those settings seem to work.

    Just thought of another symptom. I actually have 2 other domains on which I tried the Fantastico install of WP. Both of those installs displayed the same symptom of gray preview box and partial rendering of Theme code.

  8. Glenn Ansley
    Member
    Posted 7 years ago #

    I got the following message when trying to view your images folder: You do not have permission for this request /wp-content/themes/mandigo-14/images/blue/cal_bg.jpg

    chmod your theme directory to 777 temporarily to see if that fixes anything.

  9. caNative
    Member
    Posted 7 years ago #

    hmm, the file is there and the path is correct.

    Tried changing it from 755 to 777 but no help.

    And I'm checking on both PC and Mac

  10. caNative
    Member
    Posted 7 years ago #

    The weird thing is that the default Theme has an Image folder setting of 777 by default, even that isn't working right. as you can see now.

  11. Glenn Ansley
    Member
    Posted 7 years ago #

    You may have to look at some of the actual images and see what their file permissions are.

    I can actually get to your images folder:
    http://www.sftechparties.com/wp-content/themes/mandigo-14/images/

    But I don't have permission to see the files.

  12. caNative
    Member
    Posted 7 years ago #

    777 deep

    it's gotta be something else...permission look right on the dirs and images

  13. Glenn Ansley
    Member
    Posted 7 years ago #

  14. Glenn Ansley
    Member
    Posted 7 years ago #

    Make sure your FTP client is allowing you to see hidden files and then look for .htacess files in one of the subdirectories... specifically the images directory

  15. caNative
    Member
    Posted 7 years ago #

    hmm
    I dont see a htaccess file in my root dir. Could that be the culprit? If so, how do I correct?

  16. caNative
    Member
    Posted 7 years ago #

    Hey! I found the problem. Hotlinks protection was on. This was a setting in cPanel that I had turned on fairly recently.

    You helped guide me to the anser blepox, thanks a ton!
    This article also helped, not sure if it's readable by everyone... http://helpdesk.bluehost.com/kb/index.php?x=&mod_id=2&id=224

  17. Glenn Ansley
    Member
    Posted 7 years ago #

    That great! I'm glad it's working now. Be sure to change this to resolved at the top.

Topic Closed

This topic has been closed to new replies.

About this Topic