WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Removing meta entry separator from the bottom of a post (8 posts)

  1. dynamitri
    Member
    Posted 8 months ago #

    Hi guys,

    I've been struggling to solve it for the better part of today and I think it's time for me to wave the white flag here. Maybe one of you would be able to help me out.

    My page, using Prana Theme that I have customised a bit, is at http://www.dynamitri.pl

    As you probably can see, I have moved the Comment section ('Komentarze' in Polish, my native language) to the bottom of the post. For some reason, however, I seem completely unable to get rid of the backslash '\' preceding it. I have even gone to the point of opening the utility.php file on my server, which WordPress itself has no access to to the best of my knowledge. There I've found some code, which I think is responsible for that part of the post I have problems with:

    /** Prana Post Comments */
    function prana_post_comments() {
    
    	if ( ( ! comments_open() || post_password_required() ) ) {
    		return;
    	}
    
    	ob_start();
    	comments_number( __( 'Leave a Comment', 'prana' ), __( '1 Comment', 'prana' ), __( '% Comments', 'prana' ) );
    	$comments = ob_get_clean();
    
    	/** Output */
    	$comments = sprintf( '<a href="%s">%s</a>', esc_url( get_comments_link() ), $comments );
    	$output = sprintf( '%2$s<span class="comments-link">%1$s</span>', $comments, prana_entry_meta_sep() );
    	return $output;
    }

    I have attempted to get rid of prana_entry_meta_sep(); variable, but as soon as I do this, the whole site literally blows up right in my face giving syntax errors and becoming unusable.

    Now, I want to keep the entry meta separators on top of the post, where the date and tags are located, but I want the comments link to be at the bottom of the post, and clear (i.e. not preceded by any mark whatsoever). Does anyone have any idea as to how to do this in this case, and remove the problematic backslash?

    Many thanks. All suggestions will be greatly appreciated.

    Kind regards,

    Dynamitri

  2. stacyduval
    Contributor Day Volunteer
    Posted 8 months ago #

    Place the following code in your custom CSS file:

    '.entry-meta-sep {
    display: none;
    }'

  3. dynamitri
    Member
    Posted 8 months ago #

    Hi stacyduval,

    Thanks for the reply. Really appreciated. What CSS file should I place that in exactly and where, and should it be with the ' marks you've provided or not? I don't see a file called custom.css unfortunately, sorry, a bit confused here.

    Also, I'm a bit concerned it might remove all the entry meta separators outright, while I would like to keep them at the top of my post, as indicated - and only have them removed from the comment link at the bottom. But I am willing to give it a try and to see what happens.

    Thanks!

    D.

  4. stacyduval
    Contributor Day Volunteer
    Posted 8 months ago #

    Custom Style Sheets (CSS) is what gives your website the colors, fonts, margins, etc. It only changes the appearance of your website. It does not affect the code files.

    You mention you have made a lot of changes to your theme. When you make changes to your theme without creating a child theme, you might lose those changes when you update your theme. So creating a child theme is good practice when making changes to your CSS.

    However, the Prana theme comes with a customizer for your CSS file. If you go to Appearance ->Edit CSS and put the code I sent to you above, this will solve your problem without changing the theme CSS file.

  5. dynamitri
    Member
    Posted 8 months ago #

    OK, well, I don't have the Appearance -> Edit CSS option for some reason, but I have copy/pasted the code at the bottom of the style.css file in Editor - and exactly what I was afraid of has happened: it removed all the entry meta separators across the whole post. Not really what I was intending to do - I just want to have the entry meta separator gone at the bottom of the post, where the link for comments is.

    I'm happy with the date and tags being divided by the entry meta separators (backslashes) as they are now at http://www.dynamitri.pl. I just want the backslash gone from the bottom of the post, where it says

    "\ 0 KOMENTARZY - DODAJ"

    When I enter the code you have kindly provided (really appreciated), it doesn't really solve my problem, as it removes the entry meta separators at the bottom and the top of the post - in other words: across the whole post, which is not really what I'm aiming for.

    Again, thanks - but any other tips would be greatly appreaciated.

    Kind regards,

    Dynamitri

  6. stacyduval
    Contributor Day Volunteer
    Posted 8 months ago #

    try this:

    '.entry-meta-bottom .entry-meta-sep {
    display: none;
    }'

  7. dynamitri
    Member
    Posted 8 months ago #

    BOOM!

    You're a star. Thanks a lot! :-)))

  8. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 8 months ago #

    @stacy code's wrapped in backticks not apostrophes. If you don't have that key then you can use the 'code' button just above where you post.

    ;)

Reply

You must log in to post.

About this Topic