WordPress.org

Ready to get started?Download WordPress

Forums

picolight
Bug in theme when adding custom header (4 posts)

  1. ericaveit
    Member
    Posted 2 years ago #

    With the picolight theme activated, in the dashboard>appearance>header, I am unable to change the header image because of an apparent bug:

    "You can upload a custom header image to be shown at the top of your site instead of the default one. On the next screen you will be able to crop the image.
    Images of exactly 1000 × 0 pixels will be used as-is"

    I've tried many workarounds including setting my custom header in a different theme and switching over, nothing works because the widget rejects any images greater than 0px in height.

    Please help, I really love this theme! Thanks!

    http://wordpress.org/extend/themes/picolight/

  2. simpson-fan
    Member
    Theme Author

    Posted 2 years ago #

    Hmm, sounds a bit strange. I never heard anout this bug until now.

    But: In version 1.1.5 of picolight you can change the header height now. Maybe this is going to solve your problems.

  3. trevtime619
    Member
    Posted 2 years ago #

    I am seeing the same issue is ericavelt. when i upload an image that would have worked on the old theme, this is what i get.

    Warning: imagecreatetruecolor() [function.imagecreatetruecolor]:
    Invalid image dimensions in
    /xx/wp-includes/media.php
    on line 1010

    Warning: imageantialias(): supplied argument is not a valid Image
    resource in /xx/html/wp-admin/includes/image.php
    on line 63

    Warning: imagecopyresampled(): supplied argument is not a valid Image
    resource in /xx//wp-admin/includes/image.php
    on line 65

    Warning: imagejpeg(): supplied argument is not a valid Image resource
    in /xx/includes/image.php
    on line 74

  4. trevtime619
    Member
    Posted 2 years ago #

    ok so i figured out what the problem is. in appearance go to options, you need to set the height of the header here before uploading. by default its at 0. with the new update, if you wanna keep using 288 use 288, or whatever height you want. without this height set you cannot upload new images. if you already had picolight installed it doesn't set to 288 automatically. its just an interface bug. no biggie.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags