WordPress.org

Ready to get started?Download WordPress

Forums

theme panel did not seem any installed themes (9 posts)

  1. lozpt
    Member
    Posted 1 year ago #

    Hi
    I have a new installed wordpress with multi domain site. it works find as multisite feature, but I can't find any themes in network admin's installed theme panel. so I can not network enable any theme for my sites. Are there anything I was missed? Thanks!

    My stie: thegirlsbuy.com

  2. Where are you looking?

    wp-admin/network/themes.php right?

  3. lozpt
    Member
    Posted 1 year ago #

    yes,

  4. lozpt
    Member
    Posted 1 year ago #

    I can see the installed plugins from http://thegirlsbuy.com/wp-admin/network/plugins.php; but I can not seen any themes from http://thegirlsbuy.com/wp-admin/network/themes.php . my host using nginx, I can't figure out what's problem with it.
    Please give me some advice, thanks very much!

  5. What happens if you try to add new?

  6. lozpt
    Member
    Posted 1 year ago #

    It shows installed successful when try to add new theme. I can click the "network enable" link, but I can not see any theme at installed themes.

    I think the problem come out of nginx, on my test env does not have this problem. I have checked wwwroot directory ownership and rewrite rule, no problems has found.

  7. Ah, what're your rules? :D

  8. lozpt
    Member
    Posted 1 year ago #

    Did you mean rewrite rules? I have tried many rules, can't resolve this problem. for now rules as bellow.

    location / {
    if (-f $request_filename/index.html){
                    rewrite (.*) $1/index.html break;
            }
    if (-f $request_filename/index.php){
                    rewrite (.*) $1/index.php;
            }
    if (!-f $request_filename){
                    rewrite (.*) /index.php;
            }
    }
  9. Have you seen the nginx rules we have here? http://codex.wordpress.org/Nginx

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.