WordPress.org

Ready to get started?Download WordPress

Forums

Oxygen
[closed] Showcase slider not working -- template doesn't exist (29 posts)

  1. jarlep
    Member
    Posted 1 year ago #

    I installed the Oxygen theme (which is nothing short of beautiful, by the way) on one of my self-hosted blogs, following theme creator's instructions:

    • Created a static page using the Front page template (as the Showcase template is nowhere to be found – checked the editor for the php file, too)
    • Went to setting -> Reading and set the Front page to static, selecting Front page (as Showcase still not available)
    • Added a huge photo (some 2048 pixels) to initial Hello world! post, as a featured picture, of course
    • Made the post sticky
    • Parked the post in the Featured location (lower right corner)
    • Even made a Featured category, to be on the safe side
    • And zip, zilch, nada

    Now I suspect it's all to do with the missing Showcase template. If I could only get my hands on it, I'm sure the problem goes away. Cause this isn't a WordPress.com theme only, is it (which would account for my problems)?

    Looking forward to hear from you guys. Thanks!
    http://wordpress.org/extend/themes/oxygen/

  2. sonic1243
    Member
    Posted 1 year ago #

    I'm not an expert; waiting for help myself, but am using Oxygen...

    You refer to the Showcase template? Never heard of it. Do you not mean the Front Page template? The slider is called the Featured Slider.

    I'll list what I have:
    1/ A PAGE called "Home" set to "Front Page" template, makes no difference what content is in it because it's over-ridden by the contents of the Front Page template. (page-template-front.php)
    2/ Settings / Reading > Static page: "Home"
    3/ I have 4 POSTS with a "Featured Image" and below that "Location" is set to "Featured" post location on the home page. !important step.

    Works for me, but in all my experiments so far I've not seen the word "showcase" anywhere in Oxygen. I am in the process of resetting all CSS and getting complete control over the layout, also having WP-Ecommerce added on. Good luck...

  3. jarlep
    Member
    Posted 1 year ago #

    @sonic1243: Thanks a bundle for your kind response. It too went for the Front Page template, as the Showcase template, described on the theme documentation page (se below) seems absent:

    The Showcase Page template offers a featured slider for Sticky Posts. To use the template, create or edit a page, and assign it to the Showcase Page template from the Page Attributes module. If you’d like use the Showcase Page template on your front page, go to Settings → Reading and set the Front page option to Static Page. Select the page you just assigned the Showcase Page template to as your front page and then choose another page to serve as your blog page.

    Even so, and with the Front Page page (that I created, using the Front page template) set as static front page, with sticky posts, located as Featured, and more than ample (featured) image size, nothing apears on the front, save for two empty text holders.

    To my knowledge, I've done everything entirely "by the book".

  4. sonic1243
    Member
    Posted 1 year ago #

    Hmmm I suspect that page might be out of date or something then - I have it running but its definately called the Front Page template, and its nothing to do with Sticky posts; none of mine are set to Sticky (try un-stickying them). I notice there is an update for Oxygen now too but its irrelevant for me since i've renamed the template and am making it my own.

    So, if we have the same settings I've no idea why its not working for you. My test site is linen cupboard dot com slash shop.

    These forums are rather busy; as are the experts, its not easy to get your problem seen once its drifted off the first page, and we are not allowed to 'bump' them. I've asked for help fixing my two-column template file but not heard back yet. Link.
    I gotta run now but will watch this thread, good luck .. .

  5. jarlep
    Member
    Posted 1 year ago #

    @sonic1243: Thanks a lot once more. Well waddayaknow… "Un-sticking" the post did the trick – although the image comes out huge, as can be expected with that kind of original. I'll find a way around that, I expect.

    Thank you ever so much again. I've been trying to get my head around that one for a couple of days (especially as the theme documentation explicitly instructs us to make all slide featured posts sticky).

  6. sonic1243
    Member
    Posted 1 year ago #

    Grand : ) These images are supposed to resize themselves; all very clever - you upload one pic but the website makes copies for each of the locations such as a small thumbnail; and featured-slider pic etc. I've got it all running really well, just need to add my own web design around it now. Cheers.... (gone out)

  7. justinthedesigner
    Member
    Posted 1 year ago #

    @jarlep , what do you mean by "Un-sticking" ?

  8. jarlep
    Member
    Posted 1 year ago #

    @justinthedesigner: The problem is long since solved, but it appears that the theme works differently over at wordpress.com, where making posts sticky is a prerequisite for making posts/images appear as featured.

    Seeing as I'm using it on a selv-hosted blog, that requirement no longer applies, so I made unchecked the posts that I'd made sticky ("un-sticked" them).

  9. Jahanzeb Khan
    Member
    Posted 1 year ago #

    @jarlep, nice to hear that, this thread helped me fix my problem too! :)

  10. cadcardoso
    Member
    Posted 1 year ago #

  11. Misseum
    Member
    Posted 1 year ago #

    Hello all,

    @jarlep, I actually didn't get the "Un-sticky" part of your comment...
    I made tests with Oxygen themes locally but it unfornately doesn't work online...
    Still a problem with the slider, the featured post aren't on a slider but being published one under the other...
    Can you please help me ? Thanks a lot !!

    Best,

  12. scrappy123
    Member
    Posted 1 year ago #

    Oh Thank you all - especially sonic. I kept thinking you must have to have something in the Front Page template and this seems to be why it wasn't working for me. I was also guilty of the 'sticky' mistake too. Hours of headaches spared - thanks again :-)

  13. jollityeats
    Member
    Posted 1 year ago #

    I just set up the Oxygen theme and ran into the same problems as you all. The Oxygen theme on WP.com is slightly different than the one on WP.org.

    @jarlep, you are correct - Showcase template is on the WP.com site while Front Page template is on WP.org. Sticky post is used to create the featured slideshow on the home page for WP.com. It doesn't appear to be useful on WP.org. Actually, you do need to turn it off / uncheck it and select the Featured option in the Location attribute in order for the Featured Slideshow to work. See below.

    To get the featured slideshow effect on WP.org, I went into full edit mode for a post and selected the page attribute of Location, where there is an option for making the featured image appear on the home page. Select the "Featured" radio button to make it show up on the slideshow. "Primary" option will make it appear in the "recent articles" section of the home page (below the featured slideshow). Secondary will make it show up on the "more articles" section. Hope this helps. Let me know what you all encounter. I'm finding that after a great test run on the WP.com site using the Oxygen theme, its a bit disappointing to find many irregularities with this theme on WP.org (I'm using Bluehost). For example, the search bar seems to be cut off when placed in the Primary sidebar widget. Any insights?

    ----------------------
    Location:

    Featured
    Primary
    Secondary
    Do not display

    Post location on the home page
    -------------------------------

  14. queen_sheba
    Member
    Posted 1 year ago #

    Can anyone help with this?

    All my featured posts are "radio buttoned" as featured posts but my home page slider has gone wonky - it's showing the slides in a list instead of - well sliding!

    I may have deleted a plugin by mistake - any notes as to which plugins come with oxygen so I can check back and see what I've deleted?

    thanks for any help

    I also may have deleted the ability to lightbox images - not sure if it was from the same plugin?

  15. Misseum
    Member
    Posted 1 year ago #

    Hi queen_sheba,

    I exactly have the same problem as yours !!
    It worked perfectly locally but for a reason I ignore, it doesn't work properly on internet !!

    Does anyone can help please ?
    My website : http://www.culture-communication.fr

    (I've just left one article on Feature to avoid this disgraceful thing).

    Thanks !

    Best,

  16. webreid
    Member
    Posted 1 year ago #

    I too had done everything according to all the posts I read and still no joy.

    I uninstalled the existing version of Oxygen I had, re-installed it from the Dashboard using the version available through the Search function on the install page.

    I then un-stickied the posts as suggested by Sonic1243 and it works fine now.

    Thanks Sonic12434

  17. webreid
    Member
    Posted 1 year ago #

    Forgot to mention, I'm self-hosted.

    For the people looking confused about Sticky/Un-Sticky, bring up the Post, use quick-edit and un-tick Sticky over toward the right hand side.

  18. samuraicc
    Member
    Posted 1 year ago #

    Please help me with my Oxygen questions, I posted here...

    http://wordpress.org/support/topic/oxygen-several-questions?replies=2

  19. kmichelles
    Member
    Posted 1 year ago #

    I was having the same problem with the slider. This is what I did to fix my problem getting the slider to work on my self hosted blog.
    Following the advice in the forum, I made a "Home" page and set it to static, set it with "front page" as the template. I did a post with a featured image that I re-sized to a 750px width. I selected featured for location (under the featured image box). I unstuck my post that I had set to sticky. Still wasn't working. Then I finally noticed after going through everything again, I reopened my "Home" page edit, and right underneath the template selection in page attributes there is also an "order" selection that had a default 0 in the box. I changed that to 1 and it fixed my problem. I hope this helps.

  20. Sheila H
    Member
    Posted 1 year ago #

    Okay, look. I just deleted my website - erasing many hours of product because I didn't select "Showcase" at startup. Now I'm trying to start up a new blog using the same theme, only the screen does not appear giving me the option to select "Showcase". Somebody PLEASE help me with this. (I cannot get my pictures to the slider on the home page).

  21. Sheila H
    Member
    Posted 1 year ago #

    PS = do NOT tell me to set up a home page, set up another page (latest news for me), and to click on reading > static > home > latest news. I have done that ad nauseum. Also, do NOT tell me to put the picture in selected features. It's done. It doesn't work because I did NOT select Showcase at start up and now I'm apparently screwed for any site I want to build using the Oxygen theme. Sooooo frustrating!

  22. Sheila H
    Member
    Posted 1 year ago #

    I also set the test picture to 750 px wide.

  23. Sheila H
    Member
    Posted 1 year ago #

    Also, I did what kmichelles suggested with the 1 on the home page.

  24. Sheila H
    Member
    Posted 1 year ago #

    Does something need to be reset in the code?

  25. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    Which website are you working on, Sheila H?

  26. webreid
    Member
    Posted 1 year ago #

    Hello Sheila,

    Here's what I did.

    Originally I had installed the theme from a zip file. I deactivated and uninstalled the theme from the dashboard.

    I then searched from the dashboard install theme function for Oxygen.

    I installed and activated that.

    At the time I did it, there was an issue between the two themes as there is occasionally a WP .org and WP .com conflict.

    Don't ask me why, don't know. It just worked.

    Good luck and let me know how you did.

    Reid.

  27. webreid
    Member
    Posted 1 year ago #

    I should also mention, lose all the previous Sticky post advice and all the rest. Treat it like a new install and go with the directions from the dashboard theme settings.

  28. Griden
    Member
    Theme Author

    Posted 1 year ago #

    Just to clarify this common confusion - wordpress.com's version is quite different than the self-hosted Oxygen.

    The documentation for wordpress.org's (not .com) Oxygen is here: http://alienwp.com/documentation/oxygen-theme-documentation/

  29. Sheila H
    Member
    Posted 1 year ago #

    I'm really sorry to bother all of you. I figured it out on Monday and pretty much finished my site yesterday. It's at stclaressnoqualmie.wordpress.com. Thank you everyone for your help!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags