WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] theme out of place in ie 8, ie9 compatible view (6 posts)

  1. DirtyDazz
    Member
    Posted 2 years ago #

    Hi guys, I'm pulling my hair out trying to figure what's causing this bug, my layout seems fine in all browsers except iexplorer < 8 and 9 in compatible mode. I know ie is a pain in the butt at the best of times, but, this I can't work out where I've gone wrong.

    any suggestions?

    http://www.dirtydazz.com

    thanks for your time.

  2. DirtyDazz
    Member
    Posted 2 years ago #

    sry I didn't explain that too well.

    in ie, the posts are displaying off the page, to the right.

  3. Troy Chaplin
    Member
    Posted 2 years ago #

    Paste your source code into the W3C Validator and it seems there's some errors with closing divs and nav elements. I'd look at that possibility first and see if that helps any.

  4. DirtyDazz
    Member
    Posted 2 years ago #

    Cheers Troy! Validation Output: 98 Errors

    should keep me busy for a while, hehe.. at least I have something to go on now, thanks mate :)

    I'll pop back when I'm done.

  5. You can forget about the unencoded ampersand errors, but the unclosed elements and missing closing divs are the most important to fix. [Invalid] Markup Validation of dirtydazz.com - W3C Markup Validator. Scroll down in the validation report to see line numbers and source code.

  6. DirtyDazz
    Member
    Posted 2 years ago #

    thanks for the tips guys, much appreciated, I've got it at least viewable in iexplorer 8 now. talk about a crappy browser lol.

    still got a bit to do. but all is lining up again.

    The mind seems to wonder a bit more as you get older, gotta keep re reading things for it to sink in.. hehe.

    Cheers, Dazz.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.