WordPress.org

Ready to get started?Download WordPress

Forums

Theme Option Won't Work Locally (7 posts)

  1. adoerge
    Member
    Posted 9 months ago #

    Hello,

    I am trying to create a site locally using MAMP. I have downloaded MAMP and was able to load WordPress. All was working well in the dashboard till I tried to edit the theme options. When I try to upload a logo or change anything the upload and save button does not function, nothing happens. At the top of the page it says...

    "Warning-This options panel will not work properly without javascript!"

    I don't know much about javascript but I download a Global Javascript plugin and activated it (Is this all I need to do to make the plugin work?) The plugin how it is now is not fixing the issue.

    How would I go about solving this problem?

    Thanks, in advance, for any help.

    adoerge

  2. Jose Castaneda
    Member
    Posted 9 months ago #

    What version of OSX are you running? What browser are you using? What version of MAMP are you running? Have you tried deactivating all the plugins and reactivating one by one?

  3. adoerge
    Member
    Posted 9 months ago #

    I am working on 10.7.2 version of Mac OS X. I am using Safari. I just downloaded MAMP so I believe it is the latest version (version 2.1.3). I have deactivated and reactivated all plugins, still same issues. I get to the theme options page but none of the buttons will function so I am not able to change much of the design on the site.

  4. delevega
    Member
    Posted 9 months ago #

    It sounds like a permissions issue. I do not know MAMP at all. On my LAMP server I just issue the chmod command in terminal.

    Change the permissions of your folders and files within.

  5. adoerge
    Member
    Posted 9 months ago #

    Thanks for the help delevega! I am new to wordpress and mamp, could you be a little more specific where I can change these permissions.

    Many thanks

  6. delevega
    Member
    Posted 9 months ago #

    There should be a terminal (command prompt)

    Use this command (the r is for recursive)

    chmod -R 777 <name of folder>

    http://www.mac-forums.com/forums/web-design-hosting/265329-how-chmod-0777-local-folders-terminal.html

  7. keyalea
    Contributor Day Volunteer
    Posted 8 months ago #

    The WordPress codex also has information about changing file permissions. If you plan on developing your website locally on MAMP then place it on a live server, you really should learn about how 777 permissions will impact your website.

    http://codex.wordpress.org/Changing_File_Permissions

    777 is the most permissive (read, write, execute access for everyone) access and one would not want that for a folder or directory that is live. See the Dangers of 777 on the codex.

Reply

You must log in to post.

About this Topic