WordPress.org

Ready to get started?Download WordPress

Forums

Accesspress Lite
[resolved] Theme on IE (2 posts)

  1. Jhollman
    Member
    Posted 2 months ago #

    Hello again folks!

    Yeah, im using this wonderfull theme on my company's main site, i previosly made a question about a bug on the slider and it will hopefully fixed on the next release 'soon', that's cool, i can wait (^_^).

    This time im writing to report another bug i found while testing my site under the famous and troublemaker IE. I hope this helps to improve this great theme.

    Here goes the story...

    My main page uses an iFrame displaying another page from my own domain, that looks as intended on all modern browsers (tested on FireFox, Chrome, Opera, and Safari) but oviously it doesnt work at all on IE 10, page looks like shit on IE and i expendended several hours trying to figure out the why?, why IE refuses to show my page? why???...

    The issue is the low compatibility of IE with modern HTML5, especifically with the iFrames, seems that when IE finds an iFrame, it makes the whole page to run in quirks mode, therefore our lovelly page looks like garbage.

    The solution?
    Open and edit the 'header.php' file within the theme's root folder and add the following line under the <head> section:

    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>

    here is how it looks:
    <img src="http://www.cutcsa.com.uy/rss/wp-content/images/bug_report.png" alt="Cutcsa" style="vertical-align: middle"/>

    That fixed my isuues (for now) with IE.

    Regards.

  2. Jhollman
    Member
    Posted 2 months ago #

    ermmm, forgot image tagas are not allowed, lol..
    Follow this link to view the image:

Reply

You must log in to post.

About this Theme

About this Topic