WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme Not Working (7 posts)

  1. gbarr
    Member
    Posted 1 year ago #

    Hi everyone,

    I have a child theme of twentyeleven installed on my site. I recently installed the Twenty Eleven Theme Extensions page to make some customizations on the menu bar color. After I made the color changes it appeared to work fine, but a short time later my site blew up and I am not sure what steps I need to take to get the theme working again.

    http://betasite.medicinefreehealing.com/

    Any help is greatly appreciated!

  2. udaraaka
    Member
    Posted 1 year ago #

    If you just want to edit the menu bar color of Twenty eleven theme you only have to change some small values in your style sheets (CSS). First of all try to restore your theme to original twenty eleven theme at Appearance->Themes section in admin dashboard. If it works then I can help you to change the color and other settings in your main menu.

  3. Andrew
    Forum Moderator
    Posted 1 year ago #

    Can you post the contents of your child stylesheet?

  4. ClaytonJames
    Member
    Posted 1 year ago #

    You aren't importing the style sheet from the parent theme.

    /*
    Theme Name:     Child
    Description:    Child theme for twentyeleven
    Author:         gbarr
    Template:       twentyeleven
    
    (optional values you can add: Theme URI, Author URI, Version)
    */
    
    h1.entry-title {display:none;}

    Try changing it to this:

    /*
    Theme Name:     Child
    Description:    Child theme for twentyeleven
    Author:         gbarr
    Template:       twentyeleven
    
    (optional values you can add: Theme URI, Author URI, Version)
    */
    
    @import url("../twentyeleven/style.css");
    
    h1.entry-title {display:none;}
  5. gbarr
    Member
    Posted 1 year ago #

    Udaraaka, I am hesitant to switch back to the original twenty eleven theme because I have made several changes on my child theme with the footer, headings, etc.

    I changed the child theme style sheet to what ClaytonJames suggested and it did not resolve the problem.

    I am baffled at what I could have done to make it like this. The site was running well and I don't know what I could have done to it.

  6. ClaytonJames
    Member
    Posted 1 year ago #

    Your site looks fine to me now. If you are still seeing it without any style, try clearing your browser cache and then take another look.

  7. gbarr
    Member
    Posted 1 year ago #

    I reinstalled the twenty eleven theme and it cleared things up. I think the twenty eleven theme extensions plug in had fudged something up. Thanks for the help

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.