WordPress.org

Ready to get started?Download WordPress

Forums

Theme not showing on multisite installed (13 posts)

  1. juliejcdesign
    Member
    Posted 1 year ago #

    Hi installed a multi site and the theme is not showing. See http://www.juliecloutier.com/mylene/en

    it seem everything is there but the CSS is not working.

    Any idea how I can repair this? I tried to create a new site in the multisite and named it /mylene/eng but it did not work either.

    Maybe it's because I am using W3 Total Cache to maximize the speed. The main site is http://www.juliecloutier.com/mylene. It was very slow so I added the W3 total cache.

  2. What's in your .htaccess?

  3. juliejcdesign
    Member
    Posted 1 year ago #

    It's quite long, I have some stuff from the W3 Total Cache install. This is why I am wondering if the problem is from that install.

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
        </IfModule>
            AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
        <IfModule mod_mime.c>
            # DEFLATE by extension
            AddOutputFilter DEFLATE js css htm html xml
        </IfModule>
    </IfModule>
    # END W3TC Browser Cache
    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /mylene/
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:_gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} \/$
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/mylene/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index.html%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/mylene/wp-content/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core
    # BEGIN W3TC Minify cache
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteRule ^[_0-9a-zA-Z-]+/mylene/wp-content/cache/minify/[0-9]+/w3tc_rewrite_test$ /mylene/wp-content/plugins/w3-total-cache/pub/minify.php?w3tc_rewrite_test=1 [L]
    </IfModule>
    # END W3TC Minify cache
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /mylene/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress
  4. Okay, step one is turn off w3tc :)

  5. juliejcdesign
    Member
    Posted 1 year ago #

    OK it seem the problem is from W3 Total Cache, when I deactivate it from the network, everything comme back as it suppose to be. This give me a new problem, the site is very slow and I really need w3 total cache because it was solving my issue. Could I try to activate it not from the network but from each individual site?

    Or do you know of any other plugin of the same kind that would not bug the multi site ?

    Also, I would like your opinion, I always felt that multisite was the best way to build bilingual webiste. I don't like to rely on plugins for that. Do you have an opinion about this, is there another better way to build bilingual website?

  6. juliejcdesign
    Member
    Posted 1 year ago #

    I tried WP-super cache, it does not seem to improve the speed as much as the w3 total cache but it is improving it a little.

    I would like to find a way to use w3 total cache on a network but if you know both plugins, maybe you can tell me your opinion about it.

    The worst is on google chrome, it is too slow, unacceptably slow. I need to find another solution or use w3 total cache which seemed to performed better then wp super cache.

  7. W3TC has a new version which can be network activated. Which version were you using? I use it all the time and it's always worked.

  8. juliejcdesign
    Member
    Posted 1 year ago #

    I was using 0.9.2.8 it must be the latest one, since I downloaded it from wordpress.org a week ago.

    Julie

  9. 0.9.2.8 came out 9 days ago :)

    Also it became much easier on people when upgrading if they deleted and started fresh. But it does work on Multisite.

  10. juliejcdesign
    Member
    Posted 1 year ago #

    Maybe I should try to re-install it then ?

  11. Yeah, clean out the cache files in wp-content entirely. :)

  12. juliejcdesign
    Member
    Posted 1 year ago #

    What do you mean ? and how should I do that ?

  13. Delete ALL the w3tc related files.

    There are files and folders it puts in wp-content. Delete them.

Topic Closed

This topic has been closed to new replies.

About this Topic