WordPress.org

Ready to get started?Download WordPress

Forums

Theme Not Loading Fully (help) (15 posts)

  1. MrRigorous
    Member
    Posted 6 years ago #

    Hello all.

    I'm very new to WP, I've loaded a theme and it loads but not fully, there are things missing (header etc). I did a few clean installs and I can't figure out what I'm doing wrong or if I need a plug in to get it working fully.

    The theme
    http://themes.wordpress.net/columns/2-columns/4188/mushblue-10/

    My Site
    http://www.therigorouslounge.com

    Any help would be greatly appreciated.

  2. Doodlebee
    Member
    Posted 6 years ago #

    It looks like it's supposed to look to me. Just looks like the header image is replaced with a gray bar - but I can't see if that's *supposed* to be the image, because when I try to view it, I get a "Forbidden" error message. What are your folder permissions set at? Folders should be at 755, files at 644.

  3. MrRigorous
    Member
    Posted 6 years ago #

    Thanks for the reply doodlebee.

    I don't know anything at the moment about folder settings so any help with that will be great, (I'll search the forums in the interim)

    My main concerns are: the header is missing and theres a blue to black color gradient along the sides missing as well.

    Thanks again.

  4. MrRigorous
    Member
    Posted 6 years ago #

    Ok my folders are at 755 and files at 644 (0644 to be exact)

  5. moshu
    Member
    Posted 6 years ago #

    Nope. your header image file (r.jpg) is still 403 = Forbidden.
    Check the permissions!
    http://therigorouslounge.com/wp-content/themes/mushblue-10/images/r.jpg

  6. Chris_K
    Member
    Posted 6 years ago #

    Shot in the dark: could hotlink protection be enabled on his domain?

  7. MrRigorous
    Member
    Posted 6 years ago #

    Thanks for the info.

    I took the site down, I think I might now what the problem might be.

  8. MrRigorous
    Member
    Posted 6 years ago #

    Almost there.

    I removed the site from my main directory to:

    http://www.therigorouslounge.com/blog/

    Now I can see the calendar.

    The folder permissions are 755 and the files are 644 in regards to the theme in the "themes" folder.

    Should all files associated to WP be set to 644?

    Thanks

  9. Doodlebee
    Member
    Posted 6 years ago #

    Yeah, I'm still getting "Forbidden" errors when trying to view *only* the images. Maybe Handy's right - some kind of hotlink protection or something could be going on. Might want to check your root .htaccess files to see what's going on there.

  10. MrRigorous
    Member
    Posted 6 years ago #

    YEP!

    That was it, the hot link protection was on, once I turned it off the site lit up and everything was working.

    But if I turn the protection off, all the domain names I own will be unprotected.

    I do have options to choose what extensions to allow hot linking (jpg,jpeg,gif,png,bmp)etc. I just don't know if it's "safe" to have all my domains unprotected.

    I'm on Lunarpages

  11. Doodlebee
    Member
    Posted 6 years ago #

    what do you mean by "if I turn the protection off, all the domain names I own will be unprotected."? I'm not sure what you mean by that.

  12. MrRigorous
    Member
    Posted 6 years ago #

    Hey doodlebee.

    well in Cpanel I have a "hot link protection" section that lists all the domain names I've purchased.

    I can hotlink protect enable or disable all, I don't think I can select 1 domain to hotlink protect disable.

    Once I disable hot link protection every works.

  13. Doodlebee
    Member
    Posted 6 years ago #

    Ha! How funny. I use cPanel, myself - so I know exactly what you're talking about :)

    I also have hotlink protection enabled on my sites. The only thing it's used for is to prevent outside parties from "hotlinking" to your images - in essence, to keep people from linking to the images on your server and having them served up on their page, using up your bandwidth.

    You *can* edit it to allow hotlinking from yourself, however. I don't know what yours looks like, but if you add your sites to the "allowed" list, then you should be able to link to yourself, thus allowing the server to access files within itself to display to the public.

    At the beginning of the list, you should have something like this:

    !.*anekostudios\.com
    !.*brassblogs\.com
    !.*foolishvisions\.com

    Those are three of my domains that are all on the same host. I can link back and forth between these URL's because they're in my "allowed list" of places that *can* hotlink to me.

    So if you replace your own domains in that format, and place it at the very top of your hotlink list, you should be able to serve up images just fine.

  14. MrRigorous
    Member
    Posted 6 years ago #

    Thanks doodlebee.

    I tried that in the hot link protection area and for some reason it wouldn't let me edit anything.

    I got it working (so far) by tinkering with the .htaccess file.

    Thanks for the help everyone.

  15. harp21
    Member
    Posted 6 years ago #

    Well its not hotlink connection, thats disabled.
    Where do I check permissions from?
    S.

    edit: wrong window, sorry

Topic Closed

This topic has been closed to new replies.

About this Topic