WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Theme my login broke on WP 3.5 (23 posts)

  1. pe2mc
    Member
    Posted 1 year ago #

    Hi

    Love this plugin. But after update tp WP3.5 it's not working anymore.
    Hope they will solve the problem.

    Marco

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Brooke Dukes
    Member
    Posted 1 year ago #

    I am also having problems in WP 3.5. Instead of showing the form it is simply showing the shortcode. [theme-my-login-page] or [theme-my-login-form] I had to manually deactivate it to get back into my site.

  3. jamesckemp
    Member
    Posted 1 year ago #

    change it to: [theme-my-login]

  4. ripsite
    Member
    Posted 1 year ago #

    Thanks jamesckemp for posting the solution. Used phpMyAdmin to change the shortcode and all is back to normal.

  5. Brooke Dukes
    Member
    Posted 1 year ago #

    James, that worked for me too.

  6. pe2mc
    Member
    Posted 1 year ago #

    Thx @jamesckemp that is working. Great :)

  7. Brooke Dukes
    Member
    Posted 1 year ago #

    @pe2mc please mark this topic resolved.

  8. PaulieP
    Member
    Posted 1 year ago #

    Not resolved. I changed the shortcode and it did absolutely nothing.

  9. pe2mc
    Member
    Posted 1 year ago #

    Solved

  10. pe2mc
    Member
    Posted 1 year ago #

    Paulie change on the post of page the code.

    [theme-my-login-page] into [theme-my-login]

    Thats all

  11. learncomputer
    Member
    Posted 1 year ago #

    Changing the shortcode from [theme-my-login-page] to [theme-my-login] worked for me as well.

  12. noisegate95
    Member
    Posted 1 year ago #

  13. jamesckemp
    Member
    Posted 1 year ago #

    Yup, solution was found in the above thread - glad it works for everyone

  14. aimutch
    Member
    Posted 1 year ago #

    I don't have access to the DB to fix this. Is there any way to undo this without getting into the database?

  15. jamesckemp
    Member
    Posted 1 year ago #

    Open up the page in wp-admin (maybe called Login) and change it in there

  16. aimutch
    Member
    Posted 1 year ago #

    Thanks. This might not be the most direct way to do this but for anyone who got stuck like me, here's the detailed explanation. I had set this up so long ago that I had forgotten how all the parts worked together so the summary help comments above didn't provide enough detail for me to immediately figure out how to fix this. This should be enough for anyone who is still trying to work this out.

    ==============

    1. Go into the wp-content\plugins directory and rename "theme-my-login" directory to a different name. This effectively disables the plugin.

    2. Go to your regular login page. At this point, with "Theme My Login" disabled, you should see the default WP login form.

    3. Once logged in as admin, from your list of pages, find your custom login page and open it. Change the shortcode showing from [theme-my-login-page] into [theme-my-login]. Save the change.

    4. Go back into wp-content\plugins and rename the "theme-my-login" directory back to its original name.

    5. Go to "Plugins" in the Admin section and re-enable the "Theme My Login" plugin.

    6. Log out of the Admin section and go back to your login page. You should now see your "Theme My Login" based login form.

  17. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Too bad 8 people have still voted it broken for 3.5. How about you change your votes, since it is not broken.

  18. pe2mc
    Member
    Posted 1 year ago #

    I changed it into not broken. Works again. And sill love the plugin Jeff :)

    Great work

  19. aimutch
    Member
    Posted 1 year ago #

    I didn't vote for "broken" but when a plugin breaks an installation because of a change the author made, it's broken. I can't recall the last time I had to manually edit WP or a plugin to make it work.

  20. jamesckemp
    Member
    Posted 1 year ago #

    the plugin didn't change, WordPress core did...

  21. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    I actually did change the shortcode from [theme-my-login-page] to [theme-my-login] back in version 6.0. I also forgot to automatically update it. However, I'm a bit surprised at how many people just now seem to be upgrading from that version. It is pretty old.

  22. bmanfield
    Member
    Posted 1 year ago #

    I was running the latest version of 6.2.3 and it wasn't until I'd upgraded to WordPress 3.5 that it broke and I needed to change the tag.

    Made it easier to fix since my login hadn't expired on my home computer. yay!

  23. aimutch
    Member
    Posted 1 year ago #

    It must have been a combination of things because I've been keeping my plugins current. It did break after I upgraded to 3.5 but I upgraded the plugin at the same time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.