WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
[resolved] Theme My Login 6.3.4 translation (29 posts)

  1. eArtboard
    Member
    Posted 1 year ago #

    Translations doesn't work in Theme My Login 6.3.4

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Interestingly enough, they worked when I tested them. Where are you placing your translation?

  3. eArtboard
    Member
    Posted 1 year ago #

    Inside the language folder of Theme my login plugin.

    In the latest version 6.3.3 was fine...

  4. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Did you make sure the file is still there? If you placed it in the plugin folder, it would have been deleted on upgrading. This is why I now added the option of placing translation files in wp-content/languages/theme-my-login.

  5. eArtboard
    Member
    Posted 1 year ago #

    Yes is still there. I downloaded it from here http://downloads.jfarthing.com

  6. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Nothing changed with loading languages from 6.3.3 to 6.3.4 - or 6.3.5 (just released), for that matter.

  7. JEFYL
    Member
    Posted 1 year ago #

    You are not alone,I have exactely the same problem.

  8. beezeeking
    Member
    Posted 1 year ago #

    I have the same problem too.the backend is ok,but the frontend don't display.

  9. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Much of the translations are using WordPress translations. Do you have WordPress translated as well?

  10. beezeeking
    Member
    Posted 1 year ago #

    my WordPress has been translated into Chinese .and I used the official version in Chinese,for example :the profile in frontend is not translated but the backend is do,i used the responsive theme.I was so confused...

  11. beezeeking
    Member
    Posted 1 year ago #

    i tested an other plugin,it can work normally in frontend and backend.this is my picture in my site,the Translation dosn't work:http://yunpan.cn/QWQmrE82rN4VD

  12. JEFYL
    Member
    Posted 1 year ago #

    Firstly a big thank for your plugin, I use it on three sites since a lot of time. For these three sites, WordPress is completely translated into French and no problems with other plugins. With previous versions of "Theme my login" I had no problem. I used "Poedit" to verify if there was no problem in the translation file and everything seems in order.

  13. PlutonB
    Member
    Posted 1 year ago #

    I too can confirm the translation problems. The culprit I believe is that some of the translations that TML relies on are in admin-xx_XX.po which is not loaded for the frontend.

    https://core.trac.wordpress.org/ticket/19852

    On the frontend profile page for instance, the lines "First name" and "Last name" are not translated, and they are found in the admin .po file.

    Since TML is fetching from the default text-domain in the code, the quickfix is to add the strings to the main translation file for WP, however it's not very future proof.

  14. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Ah! I forgot that they separated the admin strings. So, I suppose I'll need to analyze which strings are from the admin file and re-add them to the theme-my-login domain. This won't happen until 6.4.

  15. beezeeking
    Member
    Posted 1 year ago #

    really hope this plugin does better more

  16. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    The only strings not displayed from the admin are the profile strings, no?

  17. PlutonB
    Member
    Posted 1 year ago #

    It seems so, yes. I added them to the main translation file as a temporary workaround which works fine.

  18. beezeeking
    Member
    Posted 1 year ago #

    the widget,registr error,and custom password confirm are not functioned,The following diagram´╝Ü

    http://yunpan.cn/QWuy2Miu5ZgU3

  19. beezeeking
    Member
    Posted 1 year ago #

    i have a additional suggestion:now that I have already banned users enter the admin, I think the widget shouldn't show the link of "dashboard",so should have a option to choice whether it display or not!

  20. ptriek
    Member
    Posted 1 year ago #

    Another fix is to copy the template files to your theme directory, and point the translatable strings to the TML translation file - eg. change _e( 'First name' ); to _e( 'First name', 'theme-my-login' ); - I'm using the Dutch translation file for 6.2, downloaded from http://downloads.jfarthing.com/theme-my-login/language/6.2/

  21. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    The next release will again localize all strings in the plugin within the plugin's domain.

  22. capsx
    Member
    Posted 1 year ago #

    Jeff Farthing - when will be the next release ?
    please asap ...
    thx

  23. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    No set date, yet. However, 6.3.8 should have resolved the issue, as it now load the WP admin translation on the Profile page.

  24. ivanmihov
    Member
    Posted 12 months ago #

    Hi Jeff,
    Was the problem solved? Because I installed 6.3.8 however I have the same issue like beezeeking showed on the pictures.
    Thank you.

  25. mikorka
    Member
    Posted 8 months ago #

    Same here, translation files uploaded to the language folder in 6.3.8 but still English on the user interface.

  26. sparkas7
    Member
    Posted 8 months ago #

    Hello Jeff,
    I have the same problem with the user's interface translation like the others above.Is it going to be fixed shrotly?

  27. pola88
    Member
    Posted 7 months ago #

    Hello,

    I have the same problem too !
    I have donload theme my login 6.3.9 and French translations not working
    Translations in the language file of the plugin are present
    What can we do?

    Thank you

    Paule

  28. vale_dig
    Member
    Posted 7 months ago #

    i have the same problem on version 6.3.8
    All frontend messages are in english even if i've translated the .po file in plugin/language directory and inserted the WP_LANG option in the config file (WP and other plugins work fine).

    V.

  29. UsusIpse
    Member
    Posted 6 months ago #

    Hello Jeff and thanks for the plugin. =)

    I am able to solve this issue by merging the current text domains by calling load_plugin_textdomain() from a template like so:

    <?php load_plugin_textdomain('theme-my-login' , get_site_url() . 'wp/content/plugins/theme-my-login/languages/');?>

    I think if the text domain was hooked to plugins_loaded instead of init and updated to load_plugin_textdomain that might fix the loading function.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.