WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
Theme My Login 6.3 (59 posts)

  1. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    First and foremost, let me start off with my apologies regarding my blunder on the release of Theme My Login 6.3. Apparently, beta testing was scarce - a lot of bugs were left uncovered.

    I've just released the second revision of this release, namely 6.3.2, which should address all of the major issues left with the release.

    If any of you experience any further issues with 6.3.2, please let me know here.

    http://wordpress.org/extend/plugins/theme-my-login/

  2. bmkdnf
    Member
    Posted 1 year ago #

    For some reason 6.3.2 just came as an automatic update for me from 6.2.3. I've encountered the following problems:

    1) All (non-admin) pages are blank with no html output whatsoever (they give a proper 200 HTTP header)
    2) Thinking removing the plugin and re-installing it would fix that, I tried to remove it, only to get a "wordpress error" stating "Deleting this page will cause Theme My Login to malfunction. If you really want to delete it, please deactivate Theme My Login.". So, I hacked the admin class (wp_trash_post) to remove the line that errors out so I could remove it
    3) Even after removing the /login/ redirect isn't removed (and this happens in previous versions as well, in previous versions I generally had to a do a full wordpress wipe and restore to fix; unfortunately I can't do that online that easily)

    Sidenote: Was able to downgrade back to 6.2.3 successfully

  3. oberton
    Member
    Posted 1 year ago #

    Same problem as bmkdnf. Where do I get 6.2.3 to downgrade?

  4. JohnPope
    Member
    Posted 1 year ago #

    I have the same problem with all non-admin pages being served blank.

    Disabling the plugin fixes immediately.

  5. BayTheMoon
    Member
    Posted 1 year ago #

    Thanks for the reply Jeff.
    Since your recent update, the links no longer work on the login form.

    I want to have Login/Register in my own menu at the top of the screen (baythemoon.com)so I created a page and put [theme-my-login] into its content, but clicking the Register or Lost Password links on the Login form now results in this message:

    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept
    cookies.
    Tony

  6. Hassan
    Member
    Posted 1 year ago #

    I did not experience major issues or blank pages, but I just lost all my preferences. Only the plugin pages were left intact.

  7. jan_sikora
    Member
    Posted 1 year ago #

    Once upgraded to 6.3.2 I am unable to register, reset password or view my profile.

  8. seyfer
    Member
    Posted 1 year ago #

    I can't delete 6.3.2 version.

    Plugin deactivated, but when i try delete this error on display

    "Deleting this page will cause Theme My Login to malfunction. If you really want to delete it, please deactivate Theme My Login."

    And button BACK

  9. Fla0
    Member
    Posted 1 year ago #

    seyfer do you have access to your hosting account? You should be able to delete via the file manager.

  10. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Can any of you give me errors for the blank page issue?

    Bear with me and we'll figure this out and get it working right - because, of course, this doesn't happen for me.

  11. jan_sikora
    Member
    Posted 1 year ago #

    Jeff, my site is purely in Polish so there is no point of sending any screenshots.

    But since I have upgraded to the current version whenever I want to access any of the pages:
    - register
    - login
    - lost password

    I am accessing 404 page.

    Cheers
    JS

  12. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Trfy deactivating and reactivating.

  13. articlepedia
    Member
    Posted 1 year ago #

    Hi All,

    First of all I would like to thank Jeff for his wonderful plugin. Bugs usually come that is not a problem. As a WordPress community we have to help each other.

    The upgrade problem happened to me as well. But finally I successfully downgraded to previous stable version. To downgrade you people can follow below steps:

    Note: Please Backup before doing any of the below steps

    1) First deactivate the theme-my-login plugin in the WordPress admin.
    2) Delete the folder theme-my-login from plugins folder.
    3) Open the phpMyAdmin or whatever query browser tool you can use for this task. First check theme-my-login existence in the database by querying the below statement.

    SELECT * FROM wp_options WHERE option_name LIKE '%theme_my%'

    Note: make sure to replace wp_ prefix with the one that you feed at the installation.

    You will get two records those are

    widget_theme-my-login
    theme_my_login

    the above two records should be deleted by below command:

    DELETE FROM wp_options WHERE option_name LIKE '%theme_my%'

    Now you two choice its up to you:

    1) Install the old version 6.2.3
    2) Install the latest version 6.3.2

    I installed old version successfully. But you can try 2nd option, install latest version. It could be successful.

    [ Signature moderated. ]

  14. schwarzgrau
    Member
    Posted 1 year ago #

    I recently updated and now my whole site is broken. Propably cause I'm using the code in a div placed in the header.
    I don't use the shortcodes and I don't want to use it, but after updating it creates the empty pages with shortcodes in it.

    This seems to be a good idea, for a lot of users, but it would be nice to make this shortcode-stuff optional and be a little more specific in the changelog.

  15. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Could all of you please edit your wp-config.php file and change WP_DEBUG to true. Then report back any errors you receive pertaining to TML (particularly for the blank page issue).

    Also, PHP versions would be helpful.

  16. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    On a side note, please don't download the plugin from non-official sites as it may have been tampered with. You can get previous versions of TML right here at WordPress: http://wordpress.org/extend/plugins/theme-my-login/developers/

  17. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    If anybody is willing to help in a more interactive way, I am available to chat on Skype. My username is jeff.farthing.

  18. defenderofnight
    Member
    Posted 1 year ago #

    Jeff,

    Great plugin, I love it. I am having the problem of not being able to log out at all from the admin, or from the website. I have down graded back to version 6.2.3 and it works fine.

  19. Fla0
    Member
    Posted 1 year ago #

    I have a site you can login to update and see the problems first hand.

  20. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Send info here.

  21. Fla0
    Member
    Posted 1 year ago #

    On its way.

  22. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Anybody with a real issue, such as pages not showing up, want to let me check it out?

  23. schwarzgrau
    Member
    Posted 1 year ago #

    I don't know if my problem is a "real issue" but I would update again and help you as best as I can.
    But I guess my problem is a general conflict with the way 6.3 works.

  24. Fla0
    Member
    Posted 1 year ago #

    I think the problems are stemming from conflicts with other plugins. I had deactivated all the plugins and when reactivated the site went down completly. 6.2.3 no issues

  25. Prateek Gupta
    Member
    Posted 1 year ago #

    After new updations LOGIN page is not working anymore. www.example.com/login returns the redirect loop error. and www.example.com/wp-admin redirects to wp-login.php . After 6.3.2 i got the problem of multiple login pages. And i failed to delete both of them. So i deleted them from database. But still same redirect loop problem. I'm using 6.2.3 now. And its working fine

  26. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    @schwarzgrau - I'm not even sure I understand what you are saying happened...

    @Prateek Gupta - You would need to also delete the meta values with a key of "_tml_action". This is what TML uses to determine which page for the action. You deleted the posts from the DB, leaving these meta values. Seems like it should just 404 though.

  27. schwarzgrau
    Member
    Posted 1 year ago #

    In admin I used the login-page created by TML. But I deleted the shortcode from the content and choosed a page-template called "my-login-template.php" which contains this code

    while ( have_posts() ) : the_post(); // Content vom Admin-Bereich
    		$argsmain = array(
    			'instance' => '1',
    			'register_template' => 'tml-templates/register-form.php',
    			'login_template' => 'tml-templates/login-form.php',
    			'user_template' => 'tml-templates/user-panel.php',
    			'lostpassword_template' => 'tml-templates/lostpassword-form.php',
    			'resetpass_template' => 'tml-templates/resetpass-form.php',
    			'show_title' => FALSE,
    			'show_gravatar' => FALSE
    			);
    		theme_my_login( $argsmain );
    	endwhile;

    This is what it looks like.

    And I used this code in my header to show an additional header-login-form if you click on "anmelden"

    $args_top = array(
    			'instance' => 'top',
    			'login_template' => 'tml-templates/top-login-form.php',
    			'user_template' => 'tml-templates/top-user-panel.php',
    			'show_title' => FALSE,
    			'show_gravatar' => FALSE,
    			);
    		theme_my_login( $args_top );

    Which can be seen here

    I guess this is something more special. But it would be nice if I could still use the template-code instead of the shortcode.

  28. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Why not just pass all the arguments to the shortcode?

  29. schwarzgrau
    Member
    Posted 1 year ago #

    At first I used the shortcode, but as long as I can avoid shortcodes I propably will, cause the site will have more moderators and admins and if there is nothing to adjust I don't want the settings to be avaible from the admin.
    But I guess if I don't want to change everything with the next update I propably should use the shortcode.

  30. nagad
    Member
    Posted 1 year ago #

    "I make my own translations, and it doesn't get picked up by the plugin when i put the .mo file in the language folder."

    same for me !! I'm using this version (latest)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.