WordPress.org

Ready to get started?Download WordPress

Forums

Theme images distorted or not showing after upload (6 posts)

  1. webbizdi
    Member
    Posted 5 years ago #

    I am setting up a new blog using latest version WP 2.6. I downloaded themes from the WP Theme directory and then uploaded the theme folders to the Theme folder using Filezilla.

    The screenshot image for the themes do not display on the Theme page in the admin although I see themes and can choose them. The themes when applied have all the images distorted or missing.

    Can anyone suggest what might be going wrong?

    http://www.johanneedwards.com is the site.

    Thanks.

    Jayne

  2. Michael Fields
    Themer
    Posted 5 years ago #

    You have an error in you theme's functions.php file:

    Parse error: syntax error, unexpected T_STRING in .../functions.php on line 1

  3. webbizdi
    Member
    Posted 5 years ago #

    Ok. I saw the error message right after I switched to the Squared theme. I got rid of the Squared theme for now and now have it set to the Aeros theme and I no longer have the error code but still I have no images or more accurately, what images I have are distorted others are missing. Is this a related problem? Is it the same error? If so, what would you suggest to fix it?

    I have just installed WordPress and the themes and did nothing to alter them intentionally. I installed with Fantastico and then upgraded to the latest WP using the Automatic Upgrade plugin. I am using a Windows XP machine to upload the files. I hope that helps. Oh yes, I also reintalled one of the themes but that did not help.

  4. Michael Fields
    Themer
    Posted 5 years ago #

    It looks like there was an issue when you uploaded the theme to your server - or when you unzipped it. Click on the following links:

    http://johanneedwards.com/wp-content/themes/aeros/images/rss2.jpg
    http://johanneedwards.com/wp-content/themes/aeros/images/lens.png
    http://johanneedwards.com/wp-content/themes/aeros/images/default.jpg

    These images in your theme's images directory and appear to be the only images bundled with Aeros. I would first look in your local copy of the wordpress theme and see if the images are there, If so, upload them to the following directory on your live site: /wp-content/themes/aeros/images/.

    If not, right click on the following links, save them to your computer (once open in a browser window - right click - save image as) and upload them to the directory I mentioned above..

    favicon.ico
    default.jpg
    lens.png
    rss2.jpg

    Good Luck!
    -Mike

  5. JeremyVisser
    Member
    Posted 5 years ago #

    I would say it's because you uploaded (or upgraded) WordPress or your theme via FTP while using the ASCII option.

    This means it uploads everything, including images, in ASCII. Images are supposed to be in binary format, which means when you upload them as ASCII, they get corrupted.

    I suggest trying to re-upload your theme in binary mode (it should be an option on your FTP client), and seeing how you go.

  6. webbizdi
    Member
    Posted 5 years ago #

    Jeremy, Thank You!

    I had no idea about the file setting but it was indeed set to ASCII. I changed to Binary and that solved the problem. Brilliant! Thanks!

    Jayne

Topic Closed

This topic has been closed to new replies.

About this Topic