WordPress.org

Ready to get started?Download WordPress

Forums

Hey Cookie
[resolved] using logo instead of website's name (9 posts)

  1. lele.canfora
    Member
    Posted 2 years ago #

    How can I put the logo of my website instead of the text that appears top right ? Thanks

    http://wordpress.org/extend/themes/hey-cookie/

  2. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    First things first, I'd suggest creating a child theme for your customizations so they don't get overwritten by future theme updates.

    Copy and paste the theme's header.php file into your child theme folder and make changes there.

    You can replace the call to <?php bloginfo('name') ?> on line 36 with your logo image using HTML (or whatever else you'd prefer to put there).

  3. lele.canfora
    Member
    Posted 2 years ago #

    Thanks for the quick reply, it worked beautifully :-D

  4. heroinburgers
    Member
    Posted 2 years ago #

    Hi Caroline, love the theme.

    My issue is I was able to get the logo instead of the website name, but I can't for the life of me get it to align to the center of the page. I've been playing around with the stylesheet properties, and it just won't go.

    Any ideas?

    Again, thanks for the theme. It's so elegant

  5. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    Hi there. It's hard to say without seeing an example. Try margin: 0 auto; with a fixed width and ensure you're displaying the image within a div or set to display: block.

  6. Linda_o
    Member
    Posted 1 year ago #

    Hi Caroline,
    I need a little more specifics on how to follow your directions. I can't get an image to come up. I am looking at line 36 & 37:

    <h1 class="title">" title="<?php bloginfo('name') ?>"><?php bloginfo('name') ?>

    I am replacing as follows, can you help me a bit with correcting the code?

    <h1 class="title">"><?php bloginfo('name') ?>

    Thank you!

  7. Linda_o
    Member
    Posted 1 year ago #

    Sorry - what appears above is not what I wrote...
    I think I figured out what I did wrong. Sorry for messing up this thread - you can delete my two posts!
    There are actually two places where that bit of code is written.
    I had replaced the statement after title="
    and I should have gone to the next one.

  8. lili0903
    Member
    Posted 1 year ago #

    Hey hello Caroline!

    First of all thank you very much for the "Hey Cookie" theme. It works great and it looks nice :)

    I put my logo instead of the website's name and it works perfectly on every pages when I leave the permalink settings as default. However, when I try to change the permalink settings, my logo appears only on the homepage. The link seems broken.

    Here is my website: http://www.asalicio.ch

    I'm working with a child theme, copied the header.php, changed the PHP line with:
    <img class="logo" src="wp-content/themes/hey-cookie-child/images/logo.png" alt="Logo"/>

    and put my logo in:
    wp-content > themes > hey-cookie-child > images > logo.png

    Do you have any ideas why it is not working? Am I putting the image at the wrong place?

    Thank you very much!

  9. Caroline Moore
    Member
    Theme Author

    Posted 1 year ago #

    Chances are updating your permalinks changed the URL to your logo, or possibly changed some rules in your .htaccess file. That's out of my area of expertise and not an issue with the theme, so I'd post in general help.

    If you have further questions, please create a new topic, as this one is quite old. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags