WordPress.org

Ready to get started?Download WordPress

Forums

Hey Cookie
problems with feature images.. (13 posts)

  1. rafnar
    Member
    Posted 2 years ago #

    Hey Caroline.

    your "Hey Cookie" theme is spot on! Good job!! :)

    Today Ive been having some problems, after i updated the theme. Now, my featured images wont show as a header in my posts like they used to. And I miss them...

    Have you got some trick up your sleeve for me? :)

    Best regards
    Rafnar

    http://wordpress.org/extend/themes/hey-cookie/

  2. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    Glad you like the theme! I removed featured images from single post view temporarily because I don't like the way they look, but you can re-activate them by un-commenting lines 14, 18 and 20 of single.php

  3. rafnar
    Member
    Posted 2 years ago #

    That was a fast response!! :)

    But I am very new at WordPress..what does un-comment mean?

  4. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    Examples of commented code:

    /* This PHP code is within comments */

    Remove the /* and */parts to un-comment.

    <!-- This HTML code is within comments -->

    Remove the <!-- and --> parts to un-comment.

    Hope this helps!

  5. rafnar
    Member
    Posted 2 years ago #

    It worked!

    PERFECT!!!

    Thank you very nice Caroline :)

  6. karin
    Member
    Posted 2 years ago #

    Hey Caroline, i don't know if i m writing in the right place but anyway...
    i ve just found your theme, it s wonderful! thank you!

    i m doing it for my portfolio, and i d like to put a image in the header instead of the name of the site... is it possibile? i triyed to put the code in some places but i couldnt...

    do you have any suggestion?

    hope to here from you soon :)

    have a nice day
    ka

  7. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    I don't have specific suggestions since I can't see exactly what you're trying to do, but you'd want to put your image code in header.php, replacing the site title and description pieces, then edit style.css to position the image how you want it (Firebug is helpful for work like this--getfirebug.com)

    I always advise putting your changes in a child theme so they won't be overwritten by future theme updates: http://codex.wordpress.org/Child_Themes

  8. easilydistracted
    Member
    Posted 2 years ago #

    Hi Caroline,

    First, I love your themes, so thank you for those.

    I've been trying to show the featured images on all my posts as mentioned above but my single.php file doesn't seem to have any commented lines on it, so I'm not sure exactly what it is that I'm meant to change so that the featured images show on every post without being categorized as a featured post.

    I hope this makes sense and thank you for your help.

    Rhianne

  9. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    It's possible you're running a version of the Hey Cookie theme where those lines are already active or have been removed entirely (can't remember if I deleted them in the latest release). You can find the code I'm referring to in the SVN history though:

    http://themes.svn.wordpress.org/hey-cookie/1.2.7/single.php

    (Make sure you set a Featured Image on each post on which you want the thumbnail to display, too.)

  10. easilydistracted
    Member
    Posted 2 years ago #

    Thank you so much for your quick reply, that worked perfectly!

  11. TrafficKing
    Member
    Posted 2 years ago #

    Greetings everybody! Very nice work Caroline... I'm trying to do the opposite of what there doing. Can you please help me take the feature image off post pages? It doesnt work for my site. i just want it to show on homepage and in the sidebar grid only.

  12. Caroline Moore
    Member
    Theme Author

    Posted 2 years ago #

    If you look at the SVN repo for past versions of the theme, you'll find a single.php file with commented-out code (look at the second post in this thread for an idea of what to look for). Put the commented copy of single.php in a child theme so the changes don't get overwritten by future theme updates.

  13. HighHopes
    Member
    Posted 1 year ago #

    i'm not running one of your themes.. but i did have the same issue, and probably solved in a similar manor.
    from single.php, i just deleted the following text:
    <?php if ( has_post_thumbnail()) the_post_thumbnail(''); ?>

    seems to work well. now feature image shows up in excerpt but not post.

    hope this helps someone :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags