WordPress.org

Ready to get started?Download WordPress

Forums

Theme Function issue (18 posts)

  1. t0m6
    Member
    Posted 2 years ago #

    I originally tried editing my site URL in the dashboard of my site, stupidly I thought by entering a new one this would work.

    Now, when trying to view my website http://tombryant21.co.uk/tombryant/ I am getting the following error message;

    Parse error: syntax error, unexpected T_STRING in /home/tombryan/public_html/tombryant/wp-content/themes/minimalist/functions.php on line 43

    I have tried the steps in the first section of https://codex.wordpress.org/Changing_The_Site_URL and have had no joy.

    Please can someone point me in the right direction.
    Thanks,

    Tom

  2. t0m6
    Member
    Posted 2 years ago #

    Below is the code from the functions file.

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

  3. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Please use pastebin.com for posting more that 10 lines of code.

    Using ftp or by logging into your hosted account and using the file manager, rename the theme minimalist. That will force wp to open with the default theme.

  4. t0m6
    Member
    Posted 2 years ago #

    Thanks for the reply.

    Ok I will use pastebin.com in future.

    That tip hasn't solved the problem unfortunately. Now I have a blank white screen.

  5. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Please don't bump. It really doesn't help.

    You can log in here, http://tombryant21.co.uk/tombryant/wp-login.php

  6. t0m6
    Member
    Posted 2 years ago #

    I have tried that previously but when you try to log in the URL can't be identified.

    Do you see any obvious problems in that code? According to the error the problem is in that file. I'm new to coding and creating/editing websites so I'm unable to tell.

    Thanks again

  7. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    The current problem is that url is apparently owned by http://www.gandi.net/whois/details?search=tombryant21.co.uk

  8. t0m6
    Member
    Posted 2 years ago #

    What do I need to do?

  9. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    You can try the other methods to correct the url. http://codex.wordpress.org/Changing_The_Site_URL

    You can also log into your hosted account and using the file manager your host provides or by using ftp delete the wp-content/themes folder. DO NOT delete the wp-content folder - just the themes folder. Download a fresh copy of wp, extract that folder and upload it to the server.

    In addition, you can ask your host if they can roll you back to when the site was working.

  10. t0m6
    Member
    Posted 2 years ago #

    I have tried the 'Changing the URL directly in the database' method and this has not helped. I didn't want to try any others as they don't seem to apply to my problem, they are for moving sites and so on.

    I've also tried the second option you suggested and this has not fixed it.

    I can't roll back to when it was working as I don't have that option with the hosting package that I chose, there is no backup.

    I've been in touch with my hosting, betterwebspace and they have advised me to delete one of my nameserves, gandi. My domain registar is gandi so I am confused as to whether to delete it or not.

    When I view my page it is currently just a blank white page with no error messages, to me this points to a theme issue.

    Thanks for your help so far :-)

  11. Shaan
    Member
    Posted 2 years ago #

    Change the setting using your FTP client back to its original setting. (Change the site name back).

  12. t0m6
    Member
    Posted 2 years ago #

    I'm not sure how to do this? The page loads with a blank white screen so I believe it's a theme issue?

  13. Shaan
    Member
    Posted 2 years ago #

    You can also log into your hosted account and using the file manager your host provides or by using ftp delete the wp-content/themes folder. DO NOT delete the wp-content folder - just the themes folder. Download a fresh copy of wp, extract that folder and upload it to the server.

    Let me explain this a little better (make sure you read this a couple times and ask questions before you start messing with your files - know what you are doing - make backups):
    Go to your FTP client. Go to your site directory (file) and then open the wp-content file. Inside wp-content, look for the themes folder. Delete that themes folder. Now upload a fresh copy of WordPress to your FTP client but make sure to upload it to a new, blank directory (folder). Look into wp-content. Find the new, fresh themes folder. Copy that folder and put it into the wp-content folder of your actual site. Delete the fresh WordPress installation if you do not want to keep it. That should do it.

  14. t0m6
    Member
    Posted 2 years ago #

    "Now upload a fresh copy of WordPress to your FTP client but make sure to upload it to a new, blank directory (folder)."

    Inside the parent directory folder? Inside the folder illustrated in the image link below.

    http://imageshack.us/f/94/68673501.jpg/

  15. Shaan
    Member
    Posted 2 years ago #

    Make a new folder which will be inside the root. Install WordPress into that folder.

  16. t0m6
    Member
    Posted 2 years ago #

    I installed under the folder pictured. Nothing has changed. I'm about to give up.

  17. t0m6
    Member
    Posted 2 years ago #

    I've been in touch with my hosting, betterwebspace and they have advised me to delete one of my nameserves, gandi. My domain registar is gandi so I am confused as to whether to delete it or not?

  18. esmi
    Forum Moderator
    Posted 2 years ago #

    Sorry but there is nothing we can do to help you here. You need to discuss this with your hosts and domain registrars.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.