WordPress.org

Ready to get started?Download WordPress

Forums

EvoLve
[resolved] Evolve update crashed my WP site (5 posts)

  1. hrmike
    Member
    Posted 1 year ago #

    I used the auto update function to update the theme "evolve" and when I tried to return to the update page, or any page on the site or within WP, I get error messages. My site is now down and I can't find a way to restore it. I can access the files via FTP, but don't know what to fix. The site is http://mcgoodman.com. The main error message is -

    Fatal error: Call to undefined function wp_add_inline_style() in /home/hrsunset/public_html/mcgoodman.com/wp-content/themes/evolve/library/functions/functions.php on line 55

    A second error changes the final bit to options.php on line 11. Is there a fix for this or does my site has a virus? Or do I need to bebuild it from scratch?

    http://wordpress.org/extend/themes/evolve/

  2. hrmike
    Member
    Posted 1 year ago #

    Using FTP, I deleted the files for the EvoLve theme, which gave me access to the dashboard again; then used that to change the theme. Disaster averted!

  3. artmanphoto
    Member
    Posted 1 year ago #

    I have the same problem and same error message as hrmike but my error mentions the hybrid theme and line 29. My web designer who went out of business created a custom theme called Artman that uses the Hybrid theme.

    His notes say the template files are located in /themes/hybrid. The stylesheet files are located in /themes/Artman. Artman uses templates from Hybrid. Changes made to the templates will affect both themes.

    From hrmike's post above I FTP'd into my site and changed the name of the theme to hybrid_OLD as I was afraid to delete it. Now I can get into my WP admin page and dashboard. You mention that you then changed the theme.

    Please explain how you changed the theme or what you did?

    My web designer set up WP to send me weekly database backups but I didn't realize until tonight when I researched that the themes are not a part of the database backup.

    Thanks for your help, Bill

  4. hrmike
    Member
    Posted 1 year ago #

    After I removed the EvoLve files via FTP, I was able to log into the dashboard. Once inside, I switched to another theme (twenty-twelve?), then re-installed the old version of the EvoLve theme, instead of the updated version that casued the problem. Once this was done, my site was restored. Since the old version had no problems and I still had the original theme files, this was easy once I decided to delete the files for the updated theme. If you don't have all the old files, this might not work for you.

  5. artmanphoto
    Member
    Posted 1 year ago #

    Thanks for your reply. I have a WP backup plug-in installed that emails me a weekly backup. I thought until last night that it included everything on my site but it looks like it does not include my themes. I have contacted my website hosting company and asked them if they can pull the themes folder out of my site backup before Sept. 9th. If they can I will move the "old" theme back into my site.

    Thanks again for your help!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic