WordPress.org

Ready to get started?Download WordPress

Forums

theme editor doesn't work (12 posts)

  1. myronn
    Member
    Posted 5 years ago #

    Hello guys,

    when I open my theme in theme editor, I see style.css file and it works fine. But if I want to switch to another file e.x. footer.php, I see my WordPress menu sidebar on the left, but in the middle I get a grey blank page(no editor window)! How could I fix it?

    P.S.: I have a Russian WordPress v.2.8.

  2. myronn
    Member
    Posted 5 years ago #

    I checked it in Opera, Chrome, Firefox and IE. In have this problem in all browsers.

    I figured out, that I can see ela.css too! It means, I can't see only *.php files.

  3. esmi
    Forum Moderator
    Posted 5 years ago #

    Try deactivating all plugins and check to see if this resolves the problem.

  4. myronn
    Member
    Posted 5 years ago #

    Thanks for your advice, but it didn't help...

  5. jimmy2sticks
    Member
    Posted 5 years ago #

    Hi, I have the same issue. I tried deactivating all plugins, reinstalling, and increasing memory limits.

    Any ideas?

  6. myronn
    Member
    Posted 5 years ago #

    I think, I should completely reinstall WordPress. It should help, but

    1. It's a lot of work
    2. I have no idea how to do it properly and I don't want to lose any of my information.

  7. Avantart
    Member
    Posted 5 years ago #

    There is no solution???

    I upgraded to WP 2.8, automatical upgrade
    I checked with all themes and all browsers I have at hand

    since then I cannot edit themes, the editor-area-background changes from white to grey and nothing can be edited

    I checked all permissions, I de-activated all plugins (which seems to me the suggestions when there is no real idea ....)

    nothing, no effect

    so please, help out and take care! This happened after the upgrade!
    There must be a reason for this

  8. ddarby14
    Member
    Posted 5 years ago #

    same problem - checked permissions, disabled plugins only on php pages

  9. incluye
    Member
    Posted 5 years ago #

    Can you not edit the files by FTP?

  10. vteixeira
    Member
    Posted 5 years ago #

    I have the same problem here but just with opera.

    I simply disable javascript and reload the page.
    Then when I'm done editing I enable it again.

  11. chrisaplin
    Member
    Posted 4 years ago #

    I hope this helps...

    I kept on getting 500 Internal Server Error.

    I simply activated a new theme, and then instantly reactivated the theme I was working with.

    It cleared it up!

  12. egjweb
    Member
    Posted 4 years ago #

    same problem, no solution, already reinstalled wp 2.9 and still can't edit theme files.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags