WordPress.org

Ready to get started?Download WordPress

Forums

Theme editor not working (12 posts)

  1. kjetterman
    Member
    Posted 1 year ago #

    Hello,

    After I upgraded to 3.5 on a new install of WordPress (plugin-free). I am no longer able to edit themes in the theme editor.

    I will make changes in the CSS file and save. It will "think about it" for a second, as though it is going to update my file but then the file changes back to the original stylesheet and doesn't save my changes.

    I am trying to edit the twenty twelve theme.

    Any help would be much appreciated!

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Firstly, do not edit the Twenty Twelve theme. It is the default WordPress theme and having access to an unedited version of the theme is vital when dealing with a range of site issues. First create a child theme for your changes. Or use a custom CSS plugin.

    Have you checked your site's error logs for clues?

  3. kjetterman
    Member
    Posted 1 year ago #

    Hi Esmi,

    Thank you for your response! I was trying to edit the theme to simply see if I could... however, I do understand what you are saying.

    So, created a child theme and am able to edit the CSS there. I'm also able to edit any of the other files (child theme or original theme).

    However, I can't edit the CSS of the base twenty twelve theme, twenty ten theme, twenty eleven theme or any of the genesis-framework themes. I double-checked permissions for the css files and they are set to 777.

    I also checked my error log files and there weren't any errors pertaining to my situation.

    I'm definitely stumped on this one!

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    You shouldn't be editing the CSS of any of those themes anyway.

  5. barrylau
    Member
    Posted 1 year ago #

    Esmi, can you advise? I upgraded to 3.5 and I am unable to see "editor" which was previously located under appearence.

    I have no way of editing source code or able to view any code from plugins.

    Your help is much appreciated.

    Thanks,

    Barry

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @barrylau - if you need help, please start your own thread. It does not work well to post in another person's thread.

  7. barrylau
    Member
    Posted 1 year ago #

    Thanks wpyogi but as I see my issue is the same as above I felt it was relevant to add comment but if you would like me to start a thread on the same issue that is fine.

    Thanks

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yep, I know it seems counter-intuitive to start a new thread, but we track issues by topic and posting in another person's thread makes that impossible. And really, your issue is probably not identical -- even though the symptoms may be the same, it's unlikely you have the same theme, same server, same plug-ins, etc. Also, in many cases, multiple people trying to get help at the same time dissolves into a chaotic, unworkable mess kinda like trying to have multiple conversations at the same time. So yes, please do :).

  9. barrylau
    Member
    Posted 1 year ago #

    No problem, thanks for your prompt response and help.

    Topic created: http://wordpress.org/support/topic/theme-editor-not-working-4?replies=1

  10. yaphi1
    Member
    Posted 1 year ago #

    I'm having the same problem as kjetterman under the same conditions, and while I don't need to edit the 2012 and 2011 themes, I do need to edit the Blank Slate theme. The theme itself works perfectly on other websites I administer, but for some reason, I can't save any changes in the theme editor.

    When I click save changes, my changes disappear.

  11. yaphi1
    Member
    Posted 1 year ago #

    Good news! I've found out what the problem is.

    It turns out this wasn't a wordpress issue at all. If you make changes in the editor, and the changes don't save, that means wordpress is trying to write the changes to your host, but the host has read-only ftp permissions currently set.

    Here's what that means for you.

    To fix this, go to your hosting account, find the permissions settings for "Everyone" and then change those settings from read-only. You'll want to select the "Read" "Write" and "Delete" permissions. That gives you the ability to edit template files through the wordpress editor.

    The process of changing the permissions is different for every host, so you might have to call them and ask exactly how to change permissions so they're not read-only.

  12. Raptor Josh
    Member
    Posted 11 months ago #

    I had the same issue with my site. I didn't want to chmod 777 the whole directory so I found the users which were making the changes in the scripts. The best way to enable this without compromising the security of your system is to add the users "colord" and "avahi" to the group which owns the folder containing your wordpress site in most cases this will probably be the "www-data" group. This solved my problems and no chmod 777. Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic