WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme doesn't update when edited (8 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    I've been building a blog on my PC to upload to a server when its completed (I'm so close), but one thing just started happening; when I edit the theme in the Theme Editor the blog doesn't change one bit. I tried to change the backround image (first I just changed the source in the script but that didnt work, so I took my own image and named it what the stock image used to be and no luck either), I also tried to change the message that appears when no results are found through the search box, and even though its edited in the script, the stock one still appears.

    I'm using WP 2.6, but I had no luck with 2.3.1 either :(

  2. maisteriharju
    Member
    Posted 6 years ago #

    Have you emptied the browser cache?

  3. Anonymous
    Unregistered
    Posted 6 years ago #

    I did, but still no luck :(((((((((((((((((((

  4. maisteriharju
    Member
    Posted 6 years ago #

    Are you sure you uploaded your own image over the old image? Doublecheck the url of the background-image and the image you have uploaded.

    Also check if the background-image has been coded twice in the CSS. There may be some other background-image code overriding the your background-image code. But I doubt this if you have uploaded your own image over the old one.

    If you have some other browser, try to see with that if the background-image changes. Sometimes browser cache is very difficult to get emptied.

  5. Anonymous
    Unregistered
    Posted 6 years ago #

    I did all that you said and its still not working.

    Just a reminder though, its not just the picture thing, its everything I change not showing up. Font colors and sizes, picture borders, etc.

  6. RoseCitySister
    Member
    Posted 6 years ago #

    Check and make sure you're making your changes in style.css, the main stylesheet, and not rtl.css - I was doing this once and driving myself insane until I noticed what I was doing...

  7. Anonymous
    Unregistered
    Posted 6 years ago #

    OMG it worked :D

    Thank you so much for helping me out, but for some reason wordpress didn't display the style.css file in the theme editor, just all the others.

    Thanks again though, I thought I was going to die trying to fix that damned thing.

  8. RoseCitySister
    Member
    Posted 6 years ago #

    My pleasure! Glad you got it together.

Topic Closed

This topic has been closed to new replies.

About this Topic