WordPress.org

Ready to get started?Download WordPress

Forums

Team Rosters
[resolved] Theme disappears (7 posts)

  1. lero21
    Member
    Posted 8 months ago #

    Hi Mark,

    when I get to the roster page, everything works great. But when I click on a player's name to see the bio, the entire theme disappears. Any solution ?

    See … http://embouledogues.com/wp/hockey-juvenile-alignement-2013-2014/

    By the way, when I tried to install the GS slider, WP refused it because "plugin is already installed". It doesn't update it ?

    Thanks Mark,
    Ron … a true fan of shoal summit plugins !

    http://wordpress.org/plugins/team-rosters/

  2. Mark O'Donnell
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Ron,
    You are going to have to dig into your theme and the single-player.php template. It is not unusual to have to tweak the template a bit but something here is broke bad. Here's the first few lines of your page source:

    <head>
    <body class="single single-player postid-1680 myatu_bgm_body">
    <meta http-equiv="Content-Type" content="text/html;charset=UTF-8" />

    Then further down the body and head are closed and THEN comes the page content.

    </body>
    </head>
    
    <div id="primary">
    <div id="content" role="main">

    The <body> element is inside the <head> element??? That's not right and I'm pretty sure the plugin's template is not messing with the head or body elements. Again, you are going to have to dig a little deeper and tweak something a bit.

    As for the GS Slider, the Game Schedules plugin I sent you is a BETA. The way to install it is by extracting all from the .zip archive and then moving it to your plugins directory via FTP. I would recommend testing it on a non-production site. It's pretty stable. In fact, I am preparing it for publication (documentation, readme, screenshots, I18n, etc. right now. You can check it out on my development site. And if you think I'm using some Jedi mind tricks on that site, you can check it out on this beta user's site.

    Let me know how it goes.
    -Mark

  3. lero21
    Member
    Posted 8 months ago #

    Hi Mark,
    as for the theme, I'll try to see with my theme developers.

    As for the GS Slider, I went through my FTP. I can't tell you how it goes … I can't access my backend since. Well, I'm able to log in, but all I see after is a white page. The website is working though !!!

    Ron

  4. lero21
    Member
    Posted 8 months ago #

    Backend trouble …. resolved.
    Still working on the theme ...

  5. Mark O'Donnell
    Member
    Plugin Author

    Posted 8 months ago #

    Cool. Please let me know how it goes with the theme.

  6. lero21
    Member
    Posted 8 months ago #

    Hi Mark,
    here is the answer provided by the theme's developer. Unfortunately, the problem is not resolved :-(

    Perhaps there's conflict with this plugin and equal heights script of the theme. You can edit theme's file header.php and delete this part:
    <!-- equal heights -->
    <script type="text/javascript" src="<?php echo $template_path ?>/js/equal_heights.js"></script>
    <script type="text/javascript">
    window.onload = function() {
    <?php
    $showU = array();
    $showA = array();

    $uppermodules = 0;
    $bottommodules = 0;

    if(is_active_sidebar('user5')) {$showU[0] = "'c1'";$bottommodules++;}
    if(is_active_sidebar('user6')) {$showU[1] = "'c2'";$bottommodules++;}
    if(is_active_sidebar('user7')) {$showU[2] = "'c3'";$bottommodules++;}
    if(is_active_sidebar('user8')) {$showU[3] = "'c4'";$bottommodules++;}

    if(is_active_sidebar('advert1')) {$showA[0] = "'c5'";$uppermodules++;}
    if(is_active_sidebar('advert2')) {$showA[1] = "'c6'";$uppermodules++;}
    if(is_active_sidebar('advert3')) {$showA[2] = "'c7'";$uppermodules++;}
    if(is_active_sidebar('advert4')) {$showA[3] = "'c8'";$uppermodules++;}

    ?>

    <?php if($bottommodules) { ?>
    BoxHeights.equalise(<?php echo join(",",$showU); ?>);
    <?php } ?>

    <?php if($uppermodules) { ?>
    BoxHeights.equalise(<?php echo join(",",$showA); ?>);
    <?php } ?>

    Thank you Mark

  7. Mark O'Donnell
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Ron,
    That's interesting. I don't see anything obious here that would be causing a problem. Did you resolve the problem with the <body> and <head> tags being hosed up? I wouldn't proceed any further until that's resolved. I certainly don't see anything in the above code that would impact that. In fact, the response from the theme developer is sort of lame relative to that problem.

    Are you trying to put the shortcode in a text widgets? Use the the widgets? Or what?

    Let me know. Interesting problem.

    -Mark

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.