WordPress.org

Ready to get started?Download WordPress

Forums

Delicate
two home pages links in navigation (5 posts)

  1. janel82
    Member
    Posted 2 years ago #

    I'm using "delicate" theme
    The problem I am facing is that I created a static front page as the home page, because I didn't want to have the default home page as a blog.

    I then have created a static front page, but now I have two home pages, and I checked some help forums on wordpress, their solutions is to find theheader.php file in the editor panel and to remove an extra code such as <li<?php if(is_front_page() || is_home()) echo ' class="current_page_item"';?>>">Home.
    In deleting this code, there won't be any two home pages.
    But I can't fine this line of code nowhere, so my problem still remains

    Could you please help me ? I don't know what to do.

    http://wordpress.org/extend/themes/delicate/

  2. cesaric
    Member
    Posted 2 years ago #

    I'm having the same issue with Delicate 3.5. I have an install of Delicate 3.4.4 on another site and it works fine. Looking at the header.php file, it appears there are considerable changes between the two. I'm not sure what to change to fix it though.

  3. fwdbrandon
    Member
    Posted 2 years ago #

    Easy solution: go to "Theme Options"->"General Options", Then under "Home Link Text", delete "Home" or whatever, save, and voila! No more double Home links!

  4. bsd1
    Member
    Posted 2 years ago #

    Go to 'Appearance' -> 'Menus', then create a Custom Menu, give it a name and save it, then in 'Theme Locations' to the left of your menu select your newly named custom menu as the Primary Navigation and save.

  5. cesaric
    Member
    Posted 2 years ago #

    @fwdbrandon that worked. It does leave some spacing where the deleted home link would have been but this is the exact same behavior as previously setting Settings->Reading->Front Page so I'm happy that I at least have a similar fix.

    @bsd1 that worked. It's a bit more tedious to manage pages and sub-pages this way but it does align the menu to the left nicely.

    Thanks for the tips. This helped out a lot!!!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags