WordPress.org

Ready to get started?Download WordPress

Forums

Delicate
How do I rotate my own header images? (10 posts)

  1. ktis2011
    Member
    Posted 2 years ago #

    I've downloaded my own header images but can't seem to use that for slideshow purpose. At this point, i could only

    Use each custom image as a static image (through Display header image function), OR use the theme's default 2 header images if i want a slideshow.

    Can anyone advise if there's a way to solve this problem? Ideally i try to avoid amendments at the css/html coding since i know nothing about it, unless that's the only way out.

    Please help

    http://wordpress.org/extend/themes/delicate/

  2. lamamedia
    Member
    Posted 2 years ago #

    Hi, I haven't found a way to do it without editing the code, but it is relatively easy.

    The simplest way if you only have 2 images is to replace header.jpg and headers.jpg in the wp-content/themes/delicate/images/header folder.

    If you have more than 2 images, place them all in that same folder and then edit the file wp-content/themes/delicate/header.php. Near the bottom of the file you will see 2 lines that start echo '<div><div class="tagline">... Those are the lines that load in the slideshow images. Copy and paste as many as you need and then change the tagline text and the file name just before the .jpg.

    Good luck!

  3. ktis2011
    Member
    Posted 2 years ago #

    Hi lamamedia

    Thanks for the reply. Your explanation was very clear and i did what you said. Found the 2 lines starting with echo '<div>' and changed but still it doesn't work. Even the tagline change doesn't work.

    As i said i'm really a dummy with CMS, please advise if it could be due to any below error.

    1) I uploaded my 2 images through Media. The files seem to be automatically storied in a different location (wp-content/uploads/xxxxxx.jpg), instead of the default image folder. I've replaced /images/header/headers.jpg with uploads/xxxxxx.jpg but still that doesn't work.

    2) I'm doing all these editing through the "Editor" function under "Appearance" Is that the right place i should be working at?

  4. lamamedia
    Member
    Posted 2 years ago #

    Hi ktis,

    Whoever designed the Delicate skin didn't make this easy.

    One way to fix the problem should be to move them to the folder: wp-content/themes/delicate/images/header, not the default image folder.

    Another possibility worth trying is to add "../../" (without the quotes) before uploads/xxxxxx.jpg, so it reads ../../uploads/xxxxxx.jpg -- dot-dot-slash says to look back up a level in the directory tree.

  5. ktis2011
    Member
    Posted 2 years ago #

    Hi Lamamedia

    Thanks for trying hard to solve my problem. I just gave another shot at both your suggestions. I'll ask my friend who's slightly better in CMS to take a look direct at my PC if i could have missed out anything.

    If you continue to have any good ideas, will still be great to read your replies.

  6. lamamedia
    Member
    Posted 2 years ago #

    Hi ktis,
    Sorry I wasn't able to help.
    Best of luck.

  7. nattywp
    Member
    Theme Author

    Posted 2 years ago #

    Guys, what are you doing? No need to edit header.php code!
    You need to open Appearance -> Theme Options and specify Homepage Scrolling pages

    Read theme documentation first:
    http://www.nattywp.com/blog/25/tuts-adding-slide-images/

    Cheers

  8. lamamedia
    Member
    Posted 2 years ago #

    Thanks natty!
    I tried to find the documentation but failed. Is there a list of all the available documents & tutorials?

  9. nattywp
    Member
    Theme Author

    Posted 2 years ago #

    You can check our knowledge base:
    http://support.nattywp.com/index.php?act=kb

    Cheers

  10. ruthie70
    Member
    Posted 2 years ago #

    I've contacted NattyWP support about a problem I'm having with the pagebased slideshow, but haven't heard anything back. I activate the slideshow and now my posts where I have added the <!--more--> tag, do not work anymore. It still shows the full post on the home page rather than a shorter version, with the Read More link. I apologize for posting this question here. But can't find any info about a similar problem anyone else was having.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic