WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme / CSS not rendering in remote browser (5 posts)

  1. jakabjo
    Member
    Posted 1 year ago #

    I am stumped.

    I have installed WP on IIS 7 everything works and renders fine on the local machine. However when I access the site from a remote browser (I've tried IE, Chrome, FF, Safari)the theme / CSS won't render.

    I've searched around and I haven't found anything that has helped yet.

    Could this be a file / directory permission issue?

    You can view the site at....... http://50.22.178.237/

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    That's because we don't have access to localhost.
    When referencing sources in URLs, try to use

    /wp-content/themes/yourThemename/etcetera/yourfile.png

    instead of

    http://localhost/wp-content/themes...
  3. jakabjo
    Member
    Posted 1 year ago #

    Huh?

    Could you explain how to correct this?

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    It sounds like an issue with your local server, rather than WordPress.

  5. jakabjo
    Member
    Posted 1 year ago #

    I fixed this.

    As it turns out, you need to set the "WordPress Address (URL)" to the website address in my case this was the public IP address of my WP install.

    Go to SETTINGS> GENERAL ......then set "WordPress Address (URL)" to the required Public URL or Public IP address if temporary.

Topic Closed

This topic has been closed to new replies.

About this Topic