WordPress.org

Ready to get started?Download WordPress

Forums

ColorWay
[closed] premium version is still buggy (25 posts)

  1. jiffyjack
    Blocked
    Posted 2 years ago #

    Have had consistent problems with the premium version of ColorWay. Submitted emails and support questions immediately, still no response after two weeks. Beautiful theme but if I have to fix all the bugs and they get overwritten with each update (there's already been one), it's kind of pointless.

    http://wordpress.org/extend/themes/colorway/

  2. Debby Kuhlmann
    Member
    Posted 2 years ago #

    Hi I updated mine yesterday and can no longer get rid of the page titles from my site. All worked fine until I updated - any ideas would be most welcome.

  3. jiffyjack
    Blocked
    Posted 2 years ago #

    I found two bugs in the theme. Fixed one, but no word on the other one. It's silly because there seems to be very targeted support to a couple of things and then absolutely nothing else. I found the problem right away when I purchased the premium theme and emailed inkthemes twice. Nothing. Repeat. Nothing. Went to the support forum. Nothing. Can you reinstall the old one? The free or the premium? I keep old copies, just in case. Especially for times like this.

  4. Debby Kuhlmann
    Member
    Posted 2 years ago #

    Stupidly I hadn't done a backup - my own fault. The other problem I have is my page tabs now go onto two lines and I can't remember how i fixed this originally. Really frustrating!

  5. OlegBon
    Member
    Posted 2 years ago #

    Thank you!
    All clear: set, redrafted and do not update :)

  6. jiffyjack
    Blocked
    Posted 2 years ago #

    Nareej responded to some posters about 9 hours ago, but not mine. :( So I'm on hold and trying to find the code for that first footer widget area so I can fix it.

    If you have the paid version and your tagline is not appearing in the footer, let me know and I'll post what I did to fix it here.

  7. jiffyjack
    Blocked
    Posted 2 years ago #

    BTW, my bugs were in the Dec 26 version too. The update didn't fix them, so I had to go back and re-fix the fixes I'd already made. So as far as I know it isn't going to introduce any new bugs, but it didn't fix any of the bugs I found either. Kind of a "why bother" situation.

  8. Debby Kuhlmann
    Member
    Posted 2 years ago #

    Hi Jiffyjack - mine is a free version which I updated. Have now solved most of my issues but my page tabs are still going onto a second line when they didn't before and I have no idea how to resolve it.

    Suspect it's a fault of mine rather than the software but any advise will ge greatfully recieved.

  9. jiffyjack
    Blocked
    Posted 2 years ago #

    Did you modify any of the css files? If so, which ones? Here's what I would do:

    I'd unzip the installation files and copy/ftp over any files that I had changed. That way you're eliminating any problems you may have originated with your modifications. Then go back in and make those changes again. I had to do that just because I updated and, naturally, that overwrites any modifications to css files. Mine was in a place that it wouldn't have worked to create a child class and try to fix it. I actually tried that first and then looked at it and thought, what was I thinking? Tired, I guess. :)

  10. jiffyjack
    Blocked
    Posted 2 years ago #

    What is your site URL? I'll look at it but I'm not sure I can help. I'm only going to be up for another 20 minutes and then I'm going to bed. I was working on something but I've now been up for 22 hours and my eyelids are stuck to my eyeballs. Plus the cat is getting upset. ;)

  11. Debby Kuhlmann
    Member
    Posted 2 years ago #

    I did alter a css file but can't remember which one it was - assumed it was either header or stylesheet but can't work it out.

    http://www.ingletonselfcatering.co.uk

    Support much appreciated

  12. jiffyjack
    Blocked
    Posted 2 years ago #

    You mean the part of the menu that says "links"?

    I noticed that your tagline isn't showing up. Did you put one in the General tab of settings? Because you may have to fix that too. That's a bug in the premium version.

  13. Debby Kuhlmann
    Member
    Posted 2 years ago #

    Yes, I did have it all on one line.

    Currently don't have a tagline in general settings.

  14. jiffyjack
    Blocked
    Posted 2 years ago #

    It's not you; it's the theme. I just added two bogus menu items and they're appearing below the bar just like your site. I'll look at it tomorrow. I'll post the code to fit the footer too so the tagline appears. I'm just too tired to think about the menu thing now. Remind me in about 8 hours, okay?

  15. Debby Kuhlmann
    Member
    Posted 2 years ago #

    Thank you so much - really appreciate your help. Hope you have a good sleep.

  16. jiffyjack
    Blocked
    Posted 2 years ago #

    My site: http://bit.ly/yuAvUN

    You can see what I mean about the tagline (mine's fixed), but the menu is problematic just like yours.

  17. jiffyjack
    Blocked
    Posted 2 years ago #

    See the black dot to the left of the first footer widget "Pages"? That's the bug I haven't figured out how to fix yet. Will work on it tomorrow. That and the menu thing. Wish there was some support for this theme. :(

  18. Debby Kuhlmann
    Member
    Posted 2 years ago #

    Look forward to seeing if you can fix the menu problem tomorrow.

  19. jiffyjack
    Blocked
    Posted 2 years ago #

    Okay, I'm back. Still tired, but here. So to fix the footer problem, go in and edit footer.php.

    Sorry, every time I edit this it keeps removing punctuation. I'll try again.

    REPLACE THIS LINE IN PREMIUM VERSION OF FOOTER.PHP:

    <li><a href="<?php echo home_url(); ?>"><?php echo get_bloginfo('name'); ?></a></li>

    WITH THIS ONE FROM THE FREE VERSION OF FOOTER.PHP:

    <li><a href="<?php echo home_url(); ?>"><?php echo get_bloginfo('name'); ?> -
    <?php bloginfo('description'); ?>
    </a></li>

  20. jiffyjack
    Blocked
    Posted 2 years ago #

    Right off the top of my head, I don't know what to do about the menu problem. I will keep trying to fix it though. Nothing from inkthemes. :(

  21. jiffyjack
    Blocked
    Posted 2 years ago #

    Make sure you save a copy of the original footer.php before you make any changes. Just in case something goes awry.

  22. Debby Kuhlmann
    Member
    Posted 2 years ago #

    OK code for menu bar is as follows:

    #menu li a, #menu li a.selected {
    padding-left: 5px;
    padding-right: 5px;

    }

    Did see earlier on inkthemes something about the bullet but can no longer find it - will keep looking and forward on to you when I find it.

  23. jiffyjack
    Blocked
    Posted 2 years ago #

    Brava Debby.

    Yes, all he said was that it was in the "pages" code, but I've looked through his code and it's a mess. There are about 16 different php files to do one thing. That kind of defeats the purpose of inheritance and object-oriented coding. I'm seriously thinking of re-writing it. Then I can add the features I want and not have to wait a week to get no response. ;)

  24. jiffyjack
    Blocked
    Posted 2 years ago #

    Anyway, since he said it was in the "pages" widget, I just removed that widget and used something else. Easy enough for now. I sincerely hope at some point he actually fixes it and addresses the outstanding bugs in the premium theme. I found two more tonight, ugh. Calendar widget doesn't work at all. Went from January 2012 to November 2011 and then froze. And when I added a couple of things to one of the footer widgets the entire page realigned in an odd way. So I went back to the way it was before. Second time, same thing. I'm thinking perhaps to choose another theme and come back to this one in five or six months. Maybe it will be fixed by then. Beautiful theme, but not if it's not working. And I paid for it.

  25. jiffyjack
    Blocked
    Posted 2 years ago #

    Debby,
    Nareej updated the theme and fixed the two bugs I found, but the menu seems to still be wonky. Did you hear back from him on the menu?
    I created a menu with six items and the same problem recurred. If you haven't submitted it at inkthemes, then I will. I have to admit, colorway is by far my favorite theme and I've purchased over 50 in the last three months. All of the others are seriously buggy (as in crippling your site). At least these issues are cosmetic.
    I'm going to go check out his other themes.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags