WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme changes not showing up on blog (6 posts)

  1. funnyfox
    Member
    Posted 7 years ago #

    I'm trying to make edits to the theme for my blog. When I make changes to the CSS file, they are reflected on the live blog page. But when I make changes to any other file, such as sidebar.php or index.php, they don't show up on the live page.

    What am I doing wrong?

    Thanks in advance.

  2. MichaelH
    Member
    Posted 7 years ago #

    Are you sure you are editing the correct index.php file for the active theme?

    Otherwise you may need to tell us what change you are making that is not appearing, and might even consider giving us a link to view the problem. Also a link to the theme you are using would be appropriate.

  3. funnyfox
    Member
    Posted 7 years ago #

    Well, I added a new theme via my Yahoo (my Web hosting service) blog manager that uses WordPress. When I'm taken to the WordPress interface to make edits to the theme, it provides me a box with the code and links to all the files on the side. When I click on the CSS stylesheet link and make changes to that code, those changes appear on the page. However, when I click on the links to the other files and make changes, those aren't reflected on the page. I would assume if the CSS file is the correct one, all the other files in the same list should be as well.

    I'm not sure how to send a link to the theme, since it's behind my password protected area.

  4. Chris_K
    Member
    Posted 7 years ago #

    Yahoo, eh? Running that variation on the WP-Cache plugin?

    After making the theme file change, are you clearing the blog's cache (Options -> wp-cache at a guess)?

  5. funnyfox
    Member
    Posted 7 years ago #

    Thanks HandySolo. That seems to have solved the problem. There was no explanation on that options page, and I had no idea what its purpose was, so that's why I didn't catch it.

    I only signed up for WordPress today and it keeps flaking out on me. For example, when I make a change and click the Update button, half the time I get an error message about the Post function not working. Is there some major upgrade going on with the system or is this normal behavior?

  6. Chris_K
    Member
    Posted 7 years ago #

    Is there some major upgrade going on with the system or is this normal behavior?

    You'd have to ask Yahoo! about that. We support the WP software.

    So what version of WordPress is Yahoo installing these days? Still way behind current (*cough* secure) versions?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags