WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Theme Changed Customize Options Not defined (9 posts)

  1. tiaanswart
    Member
    Posted 1 year ago #

    Hello

    I developed a new theme for a client and used the new wp customize controls for theme options.

    After developing and testing I did a fresh installation of WP and activated the theme.

    None of the theme options defaults defined in the customize panel where in the database...

    Is this a bug or normal behavior?

    How can i fix this?

    Thanks!

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Try checking your site's error logs for error messages. Have you reviewed http://ottopress.com/2012/how-to-leverage-the-theme-customizer-in-your-own-themes/ to ensure that you have set everything up correctly?

  3. tiaanswart
    Member
    Posted 1 year ago #

    Debugging was not set to true so I can't check the debug log file :(

    I quickly scanned over the page you provided the link for (thanks :D) and my theme options are defined as per standard as far as i can tell...

    Should I paste a paste bin with the options?

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Forget the WordPress debugging tools for now. They really shouldn't be used on a live site anyway. You need to look at the server/site error log. Your hosts should be able to tell you where that is.

  5. tiaanswart
    Member
    Posted 1 year ago #

    This isn't a live site ...

    It's locally hosted... Sorry should have mentioned that...

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    In that case, check your Apache error logs. The WP debug log doesn't always catch everything. Sometimes errors happen too early in the page load sequence to be logged in debug.log

  7. tiaanswart
    Member
    Posted 1 year ago #

    I use IIS locally. I just checked the log files and there are no errors for this site... :(

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Are both sites running on the same server?

  9. tiaanswart
    Member
    Posted 1 year ago #

    There is only one site :D ...

    I got tired of battling with this so I created a 'initialize_reset_settings' function to check if the option has been defined... If not then create it after theme setup :D

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic