WordPress.org

Ready to get started?Download WordPress

Forums

Catch Box
[Theme : Catch box] All in one SEO plugin - Post title prob (17 posts)

  1. Driezzie
    Member
    Posted 1 year ago #

    Hi,

    I'm using All in one SEO plugin like most people will do and it gives troubles with the catchbox theme I think.

    My All in one SEO plugin is set like this for my post title etc : %post_title% | %blog_title%
    When using the catchbox theme it shows up like this : blog_title %post_title% | %blog_title%

    e.g. :

    Normal : What a great post this is ! | My Blog
    Catchbox theme : My Blog What a great post this is ! | My Blog

    As you can see it automatically shows the blog title in front of every title, not very good for ranking in google etc.

    Can I adjust this somewhere ?

    http://wordpress.org/extend/themes/catch-box/

  2. Max
    Member
    Posted 1 year ago #

    Without being able to actually see your settings for All in one SEO, I would suggest you recheck them, I have looked at the header.php in catch-box and it is correct, containing only <title><?php wp_title();?></title> so the extra Blog Name bit is not being introduced by the theme, but has to be a plugin...

  3. Driezzie
    Member
    Posted 1 year ago #

    very weird cause when I try another theme the title shows up without mistakes...

  4. Max
    Member
    Posted 1 year ago #

    OK, I did check the theme version thats currently on WordPress theme gallery, you should probably look in the header.php file of the version you have installed, and look for the line that stats with <title> and make sure it only contains wp_title(); nothing else.

  5. Driezzie
    Member
    Posted 1 year ago #

    Nope doesn't help, this is how it looks now... looks fine.

    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta name="viewport" content="width=device-width" />
    <title><?php wp_title();?></title>
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="stylesheet" type="text/css" media="all" href="<?php echo get_stylesheet_uri(); ?>" />
    <link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>" />
    <?php
    /* Always have wp_head() just before the closing </head>
    * tag of your theme, or you will break many plugins, which
    * generally use this hook to add elements to <head> such
    * as styles, scripts, and meta tags.
    */
    wp_head();
    ?>
    </head>

    Weird thing is that it doesn't happen with categories, only with pages and single posts.

    Take a look : http://bit.ly/MyyhBP

  6. Max
    Member
    Posted 1 year ago #

    Check in page.php and single.php if you have a different header file in there. The theme may have two different header includes, and again look for the <title> tag. I don't know the All in one SEO pack plugin well, I have grown up on Joost de Valk's WordPress SEO, but I do know some of the SEO plugins allow different templates for say pages and archives.

  7. Driezzie
    Member
    Posted 1 year ago #

    I used another SEO plugin and everything works fine now.

  8. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    Hi Driezzie,

    Can you add in the Site URI here so that I can see what's going on with your site?

    The wp_title is filter through catchbox_filter_wp_title() function which you will find in function.php file.

    I just test it in my site and it is working fine with All in One SEO Plugin.

    Regards,
    Sakin

  9. loza57
    Member
    Posted 1 year ago #

    Hi,

    Thought I would highjack this thread seeing as it's exactly my problem. Same thing happening to me, I have All In One SEO installed and have been using it for years. On the posts that I have entered info in the plugin, the post title comes up fine. In those that I haven't, it comes up as

    Blog Title Post Title.

    I recently changed the theme, I love the layout and look, but my visitors have already dropped substantially and I am sure that this isn't great for SEO.

    When I disable the plugin it turns into Blog Title >> Post Title. I have around 300 posts and I really don't want to be losing the benefit I already have. Is there some solution so that i can keep All in one SEO and the theme running together? I have been looking through the php files but honestly am struggling in that area.

    My site:

    http://laurensfitness.com/

    Here is an example of a post without the All in one info plugged in.

    http://laurensfitness.com/2012/07/29/plica-syndrome/

    Appreciate the help!!

  10. loza57
    Member
    Posted 1 year ago #

    It is also happening on tags.

    http://laurensfitness.com/tag/trigger-points/

    I really appreciate any help, I would like to continue using the theme if i can find a solution.

  11. Andrew
    Forum Moderator
    Posted 1 year ago #

    Loza57,

    You're more likely to receive help if you create your own thread on the issue.

  12. loza57
    Member
    Posted 1 year ago #

    Will do!

  13. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    Loza57,

    Can click on "All in One SEO" under Settings in your WordPress Dashboard. Then uncheck "Rewrite Titles". This will fix your issue.

  14. loza57
    Member
    Posted 1 year ago #

    Thank you,

    Now it comes up as

    Laurens Fitness >> Post Title

    My best search engine results were

    Post Title | Laurens Fitness

    Is there much difference SEO wise, as I don't necessarily like change if it is affecting my rankings... is there any way to have it back this way?

    Thank you for the reply, very quick and helpful!

    Lauren

  15. Catch Themes
    Member
    Theme Author

    Posted 1 year ago #

    Hi Lauren,

    Actually that doesn't make any different. In our next version update, I will make it to | as it is being commonly used. So, wait for the new version update. But I assure that it doesn't make any significant difference in SEO.

    Regards,
    Sakin

  16. loza57
    Member
    Posted 1 year ago #

    Great thank you for your help, much appreciated.

  17. Cyann
    Member
    Posted 11 months ago #

    Greetings - I am having the same problem as others with content showing up as: blog name - post title - blog name. I want to eliminate the first blog name but do not know how? The previous answers to this question didn't help at all. Everything else works fine except for this issue. Not a techie - so need a user friendly answer. Please help.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic