WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Theme: Catch Box] issues with child-theme, width, and menu links (6 posts)

  1. samavay
    Member
    Posted 1 year ago #

    Hello,

    Background: I have Catch Box 1.4.1 on WordPress 3.4.2. I'm running with Single-Column No Sidebar. I'm also running wp-ecommerce 3.8.8.5 with several additional plugins.

    I have created a custom menu that links to several pages as well as to product categories from wp-ecommerce.

    On a laptop running 1366x768, Catch Box uses the following to limit page width.

    /* One column */
    .one-column #page {
    	max-width: 690px;
    }

    If I update the style.css in the theme to be

    /* One column */
    .one-column #page {
    	max-width: auto;
    }

    Then the screen fills up more of the window properly instead of being scrunched up. The menus still work correctly.

    Where this goes wrong is when I try to create a child-theme to have the page width changes persist across updates.

    /*
    Theme Name: Catch-Box Child
    Description: Child template by Sam
    Author: Sam
    Version: 1.0
    Template: catch-box
    */
    
    @import url('../catch-box/style.css');
    
    /* One column */
    .one-column #page {
    	max-width: auto;
    }

    When I do this, the pages look correct, but the menu links to product categories in wp-ecommerce disappear.

    I've tried disabling every plugin except wp-ecommerce and it still doesn't work.

    How do I get both the width to display correctly as well as having the links to the wp-ecommerce pages display?

    Thanks,
    Sam

  2. Catch Themes
    Member
    Posted 1 year ago #

    can you send me the URL so that I can see what is going wrong...

  3. samavay
    Member
    Posted 1 year ago #

    Sakin,

    Unfortunately I'm running this on a VM. I started with Bitnami and their WordPress stack and added in various themes & plugins.

    I'll see what I can do though.

    Thanks,
    Sam

  4. samavay
    Member
    Posted 1 year ago #

    Sakin,

    We've finally been able to put a test onto the webhost. A simple 1 page is at http://www.averygallery.com/wordpress

    As you can see on the main page, the text is centered in a small area. On a higher resolution screen it looks tiny.

    We've set it Catchbox default layout to be one-column no sidebar. I haven't tried it with a child theme yet. Nor have I added menus and more pages yet. I'll work on that soon.

    Shouldn't Catchbox fill the screen more in single-column mode?

    Any thoughts on this?

    Thanks,
    Sam

  5. Catch Themes
    Member
    Posted 1 year ago #

    Hi Sam,

    When you select the One Column with no sidebar then the display that is showing in http://www.averygallery.com/wordpress/ is correct.

    But id you want to show the full width then you can add the following css in "Custom CSS" Box in your Theme Option under Appearance Tab in WordPress Dashboard:

    .one-column #page {
        max-width: 690px;
    }

    Regards,
    Sakin

  6. samavay
    Member
    Posted 1 year ago #

    Sakin,

    This works great for the site! Thank you very much!

    Sam

Topic Closed

This topic has been closed to new replies.

About this Topic