WordPress.org

Ready to get started?Download WordPress

Forums

Brunelleschi
Version 1.5.5 causes IE 8 crash (5 posts)

  1. bobk88
    Member
    Posted 2 years ago #

    Brunelleschi 1.5.5 causes IE 8 (on Windows XP) to crash before the page finishes loading. I don't have a Windows machine, but this is from a reliable source with a brand new computer.

    As of this writing, IE 8 is the most widely used version of that browser, with almost double the users of IE9, according to browser stats at w3schools.com. I realize IE is probably the most despised browser among developers, but I think the user base is too large to ignore.

    I tried 1.5.6 from the author's web site (it's not at the WP site yet); it doesn't cause the crash, but it causes major formatting problems in the latest versions of Safari, Firefox, Chrome, and Opera on my Mac (Mac Pro, 16 GB RAM, OS 10.6.8) as well as in Firefox 10 and IE 8 on Windows XP.

    http://wordpress.org/extend/themes/brunelleschi/

  2. lunaman
    Member
    Posted 2 years ago #

    Hi there,
    I think I've found the culprit.
    I had similar reported problems from clients with IE7 and 8, and Adobe Browserlab fails to load and reports a page error for those browsers too.
    Brunelleschi uses Modernizr, which has an IE crash reported here:
    https://github.com/Modernizr/Modernizr/issues/332

    So I tried updating Modernizr to the fixed 2.5.3 rather than the 2.5.2 supplied with Brunelleschi, even with 1.5.6 (which still crashed for me).

    No joy, but I took a gamble on respond.js, and indeed the latest version from https://github.com/scottjehl/Respond
    downloaded and called from functions.php (in a child theme in my case)
    fixed the crash and the test load in Adobe Browserlab.

    If you're using a Child Theme, and want to keep your newer JS files in your own theme, simply copy over the functions.php file from the Theme directory, and delete everything except the brunelleschi_register_assets function. Then edit the Modernizr and Respond.js lines to refer to your local, up to date, copies of respond.js and modernizr. js
    If you need to generate the modernizr script again to download at
    http://www.modernizr.com/ then Brunelleschi appears to be configured with EVERYTHING included.

    Hope this works for you as well.

  3. bobk88
    Member
    Posted 2 years ago #

    Thanks very much, lunaman.

    I had to move on to another theme - lack of IE8 support was a deal-breaker, since it's the most-widely used Windows browser.

    If that new theme doesn't work out and I return to Brunelleschi, I'll give these fixes a try.

    Thanks again for sharing the info.

    Bob

  4. thisiscmt
    Member
    Posted 2 years ago #

    Note that Brunelleschi 1.5.8, the latest as of this writing, includes a newer Respond.js and does in fact fix the IE 8 crash bug.

  5. bobk88
    Member
    Posted 2 years ago #

    Thanks for the update - glad that's fixed.

    However, for better or worse, I don't plan on returning to Brunelleschi, as there were other problems besides the IE8 crash. I ended up with a paid theme framework called Catalyst which is better-supported and is easily customizable via hundreds of options in the dashboard - I really like it.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic