WordPress.org

Ready to get started?Download WordPress

Forums

Brunelleschi
one column no sidebar page template has 27% left margin on #main.. (7 posts)

  1. siriusalpha
    Member
    Posted 2 years ago #

    hi,

    when i create a page with the "one columnn no sidebars" template in brunelleschi theme, it displays with a 26% left margin
    (in page head is css:
    #main { margin-left: 26%;}

    so 2 questions:
    1. how and from where this css is inserted into the created page?
    2.how do i change this erroneous behaviour (margin should be 0 i think on the full width page)

    http://wordpress.org/extend/themes/brunelleschi/

  2. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    CSS code is usually in style.css file -- though it may be in another stylesheet or inline or internal. Using Firebug is the best way to find the CSS that you want to change.

    If you post a link to your site, someone can likely give you more specific help.

    Be sure you are using a child theme to make any changes to your theme.

  3. siriusalpha
    Member
    Posted 2 years ago #

    yes usually, but this is not in style.css. Watching the page in firebug, this css is present in the head of the page, and might be generated when creating the page inside brunelleschi theme.
    i cannot find myself any reference to this in brunelleschi theme files, because i am a noob. :)
    sorry the site is not online. i was just testing the brunelleschi theme.
    But the problem is easily reproduced if you install brunelleschi theme with 2 columns on the sides and then create a page with the one column no sidebars template.

  4. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    The header.php file has all that internal stylesheet code -- which is generated according to which theme option is selected. A way to get around trying to change the width in there is to use the CSS !important code:

    #main {
         margin-left: 0 !important;
    }

    Put that at the bottom of your child theme stylesheet and see if it works.

  5. siriusalpha
    Member
    Posted 2 years ago #

    sorry, think i solved the bug myself for the time being.
    The css was in header.php of brunelleschi theme, which does replace settings in style.css.
    my solution for the moment is adding inline css in onecolumn-page.php
    any more elegant solution is welcome! :)

  6. siriusalpha
    Member
    Posted 2 years ago #

    ok WPyogi, thank you.
    if i understand it, i should change the specific #main .one-column class settings in style.css to !important; and it will overrule the settings in header.php..
    is that right?

  7. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    IN theory -- though CSS can be cranky sometimes... Try it and see. Or stick with inline -- if that works.

    Frankly, I'd be a bit reluctant to use a theme that has tons of CSS in the pages -- as it makes it very difficult to make changes. (though it could be that I'm missing something with that theme as I've not used it other than just looking up the header.php for this question)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic