WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Bonpress theme Randomly Disappearing Timestamps (3 posts)

  1. justbishop
    Member
    Posted 10 months ago #

    I've noticed that twice now, when the most recent post is superseded by an even newer one, the new second-in-line post's timestamp isn't displayed anymore (as in, it was displaying fine before a newer post was posted). You can see this phenomenon in action at my site, as it just happened with posts made yesterday:

    http://www.ashleyheckman.com

    When I go to edit the timestampless post, the correct post time is still there (on the edit post screen of the admin panel). Why on earth would it not be displayed?

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    I'm sorry but as you are using a non-WPORG theme, you need to seek support from the theme's developers - paid or otherwise. We only support themes downloaded from wordpress.org here. Try http://www.wpzoom.com/support/

    FWIW, it sounds like your theme uses the_date() which - by design - only shows the date/time stamp on the newest post in any given day. If you want to show a timestamp on every post, the theme has to use the_time().

  3. justbishop
    Member
    Posted 10 months ago #

    I'll look into the the_date v. the_time thing, thanks. Weird though, it's not that it only shows the timestamp for the latest post. It shows it for the latest, then not for the next newest, then it shows a timestamp for the next few, and then not for one. It seems very random.

    ETA: Looks like the timestamp was wrapped in an if statement for theme option purposes. I just took it out of there and replaced the_date with the_time. Messing around with the_time got me all fixed up, thanks ;)

Reply

You must log in to post.

About this Topic