WordPress.org

Ready to get started?Download WordPress

Forums

SuperSlider-Show
[resolved] Theme and superslider-show issue (20 posts)

  1. GodSponge
    Member
    Posted 1 year ago #

    WordPress version: 3.5
    Superslider plugin: 1.6
    Plugin version: 2.8

    I inserted [slideshow id="55,56,54,53,51,52,50,49,48,47" width="320" height="240"] and nothing shows up on the page at all. When I just insert [slideshow] I get the first image in the WP media library and it just sits there doing nothing.

    I looked in the php of my theme and found these:

    calls to mootools-core.js and mootools-more.js

    and these lines below.
    wp_dequeue_script( 'mootools' );
    wp_dequeue_script( 'jquery' );
    wp_dequeue_script( 'jquery.no.conflict' );

    It looks to me like the theme already calls mootools and disables other calls for it. Is there a way I can make the plugin recognize that mootools is already available? Is there anything else I can do? The plugin seems like it would be perfect for what I'm trying to do, but I just can't make it work. BTW the theme is Shape5 Vertex.

    http://wordpress.org/extend/plugins/superslider-show/

  2. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    Superslider plugin: 1.6 uses mootools 1.4.5
    you need to ensure that the theme is loading the same version of mootools.

    HTH

  3. GodSponge
    Member
    Posted 1 year ago #

    Looks like it uses mootools 1.3.2. Do you know how I might prevent my theme from loading the old mootools or replace the old version with 1.4.5?

    I'm using a child theme to mod. I'd love to be able to do it that way rather than modifying the original theme.

  4. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    You'll have to ask your theme developer.
    as for preventing the theme from loading mootools, depends on how the theme loads javascript.

  5. GodSponge
    Member
    Posted 1 year ago #

    I switched themes to twenty eleven and twenty twelve and both give me an unresponsive script error when loading the show. I do at least have a box drawn with these themes though.

  6. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    I would need an url to trouble shoot for you.

    I have not been able to reproduce the error.

  7. GodSponge
    Member
    Posted 1 year ago #

    Thank you for taking so much time to help me with this issue.

    The test site is up at pcswebtest.com
    I haven't really added anything to this site yet.

    Plugins used: SuperSlider, SuperSlider-Show, and Widget Context.

    I tried disabling widget context to see if that did anything, but it didn't.

  8. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    You can try the following:
    deactivate superslider, just use the superslider-show plugin for testing.

    The code states that the images you are trying to use are:
    http://s416322770.onlinehome.us/cwjc.net/wp-content/uploads/2013/01/CWJC_webheader_color-01.png

    Also, the images are wrapped with this:
    <a class="" title="">
    Which means that information is missing.
    It seams that there is some type of issue with the cross domain.

  9. GodSponge
    Member
    Posted 1 year ago #

    Well the script error came from me using ids= instead of id=

    Now that I've fixed that, the slideshow has completely disappeared again.

    http://s416322770.onlinehome.us/cwjc.net is the url I've been using to test. I just forgot that I had both pointed there.

    when I use [slideshow id="55,56,54,53,51,52,50,49,48,47"]
    there is nothing at all in the source showing that any slideshow should be there.

    Is it that I'm inserting the slideshow shortcode from the html editor instead of visual? I thought that that was the way it was supposed to be done.

  10. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    I'll be taking a closer look at this issue tomorrow.
    Hope to have the problem resolved.

  11. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    Hello GodSponge,
    I have been able to reproduce this error.
    However I have not found the cause.
    It is not a javascript error, nor a php error, nor a 404 in fact all debugging has returned clean.

    I do believe that I have eliminated the superslider-show plugin as the cause of this issue. After testing in various WP installations on various servers. I have found that the plugin works as expected in most situations. I have found set ups where it does not work. However in those situations where it does not work, I've also encountered that in fact none of the shortcodes work, neither those of plugins nor those shortcodes of the WP system.

    I have also encountered set ups where shortcodes work on one post but not on another post within the same site.

    You may want to test shortcodes on your site.
    try with another post inserting the WP [gallery] for example.
    or another plugin which uses shortcode, just to see what happens for you.

    I'll continue to track and search for a solution to this issue, it does seam magical.

  12. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    Here's a realization for you.

    with superslider-show shortcode, when you add an id list to the shortcode such as:
    [slideshow id="12,34,45,56"]
    The id was not meant to be an image id, in fact it is meant to be a post id.

    The WP system gallery shortcode now uses image id.
    [gallery idz="12,34,45,56"]
    which seams not to be working for the slideshow plugin.
    This is going to cause lots of confusion, and I'll have to find a solution to remove that confusion and ensure that it works in any situation.

    Regardless of this understanding, I am still having complete shortcode failure on various installs.

  13. GodSponge
    Member
    Posted 1 year ago #

    I do seem to have an issue with inserting some shortcodes. I do not, however have any issue inserting gallery shortcodes.

    I do not intend to make individual posts out of my images. Is there some way to make the slideshow work with just images? Or do you mean something else that I'm missing? (I will probably feel dumb when you answer)

  14. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    Yep, if the images are attached to the post you don't have to define any id, at all. The shortcode looks for the images attached to the post. They are automatically attached if you upload them while on the edit post screen.
    As I mentioned, I will look into a solution to define weather id is post or image.

    ps. what issues do you have with shortcodes? Which shortcodes also fail for you?

  15. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    I've just updated the ss-show plugin, (2.9) it now will work with the shortcode : [slideshow ids="12,13,14"] where the id numbers are images rather than post ids. The option of id="120,130" still works where the numbers are post ids.

    As for the empty screen, I have no idea what the cause id. I found that the theme 2012 stripped all kinds of post code, under certain situations. Not related to the plugin ss-show.

    ps. if you are inclined to, you could post a review here.

  16. GodSponge
    Member
    Posted 1 year ago #

    Well I still seem to be getting an error with the javascript not responding.

    A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

    Script: http://s416322770.onlinehome.us/cwjc.net/wp-content/plugins/superslider-show/js/slideshow.js?ver=2:520

    I built mootools version 1.4.5 and replaced the version in my theme. The theme seems to have no problems with the new mootools. I am no longer having the slideshow completely removed from the code though. I get the box and the busy animation until it says the script isn't responding.

  17. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    Hello

    I built mootools version 1.4.5 and replaced the version in my theme.

    Could you explain in more detail what file went where?
    You did not need to replace the mootools files in the ss-show plugin folder.
    Could you post here the shortcode you are using.

    I have just successfully posted with this shortcode:
    [slideshow ids="1768,1692,1690,1689,1281" show_type="push" image_size="medium" pop_size="large" height="360" width="420" delay="4000" duration="1200" linked="lightbox" fast="true" captions="false" overlap="true" thumbnails="true" thumbsize="thumbnail" mouseover="true" paused="false" random="false" loop="true" loader="true" controller="false" center="true" resize="true" clear="left" ]

  18. GodSponge
    Member
    Posted 1 year ago #

    Since my theme didn't have the correct version of mootools, I built version 1.4.5 and replaced the js file that my theme uses. That way the theme and your plugin would be on the same version. I did not change anything in the folders of your plugin.

    If it will help with this problem, I'll send you a login to the site. Is there some place I can send that other than on here?

    the code I'm using is this [slideshow ids="55,56,54,53,51,52,50,49,48,47"]

  19. Daiv Mowbray
    Member
    Plugin Author

    Posted 1 year ago #

    Sure, we could take this off forum , contact me through my user name.
    mention ref:GodSponge.

  20. GodSponge
    Member
    Posted 1 year ago #

    email sent

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags