WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] The wordpress tool bar at the top of the screen has gone? (12 posts)

  1. supersimplicity
    Member
    Posted 3 years ago #

    I recently created a theme from scratch - http://www.supersimplicity.co.uk

    I should say that this is the first theme I have ever created and my first attempt at php and css.

    Since installing the theme, everything seems to work fine except the wordpress tool bar at the top of the screen. Instead of the tool bar I see a greyish space where the toolbar should be.

    I’m not sure if it’s something in the code which I'm missing?

    Any help would be much appreciated.

    Kind regards.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Check that you haven't disabled the Admin bar in your profile.

  3. supersimplicity
    Member
    Posted 3 years ago #

    Hi Esmi, thanks for the reply.

    The "show admin bar - when viewing site" is checked.

    I also unchecked this option to see the effects and found that the grey space where my admin bar should be disappears.

    So when that option is checked I see a grey space where the admin bar should be, but no buttons or options.

  4. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    1) Verify that you have the wp_footer() template tag, immediately before the closing </body> tag.

    2) Check functions.php, to verify nothing is filtering out the display of the Admin Bar.

    3) Check for any JS errors, using Firefox Firebug or Chrome Developer Tools

  5. supersimplicity
    Member
    Posted 3 years ago #

    Hi Chip, Thanks for the options you have given. I am new to wordpress and coding so slightly confused with your response.

    1) what is the wp_footer? I do not have that immediately before the closing body tag, and when I add it, it screws up the footer?

    2) what is the fuction I should be calling for or looking at?

    3) I have firebug, how would I use it to check for errors? or what should I be looking about for?

    in my settings I ticked both the boxes for how to view the admin bar, so it is viewable in the dashboard and on the site. When I am in dashboard I can see and use the admin bar.

  6. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    1) <?php wp_footer(); ?> is a template tag, that applies a very important hook in the Theme. If it's not there now already, then it needs to be there.

    (When you added wp_footer(), did the Admin Bar appear?)

    2) Look for add_filter() or remove_filter(), in combination with "Admin Bar".

    3) You should be looking for JavaScript errors.

  7. illustrata
    Member
    Posted 2 years ago #

    Hi, I'm having the same issue. Where exactly would one look for wp_footer() template tag? And also javascript errors in Firebug, would they be obvious?

  8. Chip Bennett
    Theme Review Admin
    Posted 2 years ago #

    Normally, the wp_footer() template tag is immediately before the closing HTML </body> tag.

    Look in "footer.php", in most Themes.

  9. illustrata
    Member
    Posted 2 years ago #

    Hi, I found the problem. Another thread reported that the cookie set by the previous version of WP is slightly different than the new cookie. So I did as the poster did, logged out and logged back in, and there was the bar.

    Maybe this will be the case for someone else. A painless solution, at any rate...

  10. supersimplicity
    Member
    Posted 2 years ago #

    when i add the wp_footer() to the footer.php and update the site, nothing happens apart from the word "wp_footer()" appearing at the bottom of the page, under the footer

  11. Chip Bennett
    Theme Review Admin
    Posted 2 years ago #

    when i add the wp_footer() to the footer.php and update the site, nothing happens apart from the word "wp_footer()" appearing at the bottom of the page, under the footer

    ...did you wrap the function call in PHP tags? e.g.

    <?php wp_footer(); ?>
  12. supersimplicity
    Member
    Posted 2 years ago #

    I had wrapped the tag.

    I tried it again today and it seems to have done the trick, so thanks you Chip, your help was much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic