WordPress.org

Ready to get started?Download WordPress

Forums

The version 2.6 will not work! Dont install! (69 posts)

  1. jinge
    Member
    Posted 6 years ago #

    A great deal om errors, I cant log in to my blogg and the permalinks don´t work like they should.

    I guess that thousands of blogger is in the same situation in this moment and we need help in a hurry. Who of the staff on

    WP are helping?

    What is the problem?

    The latest message when I tried to log in are:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, support@one.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    WHO looking at this kind of problems NOW??

  2. pcmt
    Member
    Posted 6 years ago #

    Before you demand solutions from others, please remember, WordPress is a piece of free software.

  3. jinge
    Member
    Posted 6 years ago #

    Sure my friend! I guess the astronauts are happy the crew not working at NASA... :-)

  4. Edde Beket
    Member
    Posted 6 years ago #

    I just upgraded without any problems.

    ...and I did it the ugly way: overwriting the existing files and without disabling all plugins. (I know... but I like living life dangerously. Besides, it was on a test installation ;) )

    The "Internal Server Error" sounds like a problem with permalinks to me. Remove your .htaccess (make a BACKUP first!) and have wordpress re-write the file.

    More on this topic: http://codex.wordpress.org/Using_Permalinks

  5. jinge
    Member
    Posted 6 years ago #

    Done that Edde! My htaccess is in the Binary heaven and nothing is changed. I tried to run upgrade.php again but still I have internal error...

  6. Edde Beket
    Member
    Posted 6 years ago #

    Have you forced the creation of a new .htaccess by changing the permalink settings? - to "default" and back to nice "custom" ones.
    Does the error disappear if you switch to "default" permalinks (the ugly ones)? This probably means mod_rewrite is not enabled which also creates an error like the one you describe.

    Also, check your file permissions. Are the /admin/ files at least readable? The Internal Server Error is an Apache thing, so even without the upgrade (which has to do with the database) you shouldn't see this error.

  7. Samuel B
    moderator
    Posted 6 years ago #

    So far I've installed 2.6 16 times without error.
    500 errors are typically webserver problems.

  8. 7milesdown
    Member
    Posted 6 years ago #

    Have you tried an install on a Windows Server using the permalinks?

  9. Greg Rickaby
    Member
    Posted 6 years ago #

    I upgraded on my Hostgator account last night...what a mess :(

    Permalinks don't work. I have hundreds of indexed pages on Google! Gone!

  10. jinge
    Member
    Posted 6 years ago #

    I renamed .htaccess and that made it possible to login. But still it is problems with permalinks. When I run with default it works, but when I change to custom all will stop with a 404-message.

    I have tried to reinstall 2.5.1. and the problems are still there. It seems like the new WP have done some database change…

    But there is more problem. WHERE should I go for help. There is the same question in many topics now, I guess the moderator should start a topic named “problems with 2.6 permalinks”.

  11. Evita
    Member
    Posted 6 years ago #

    Updated just this minute two blogs without any problems. No login problems, no permalnk problems, circa 40 plugins working fine.
    Great new version, congratulations!

  12. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I have tried to reinstall 2.5.1. and the problems are still there. It seems like the new WP have done some database change…

    Sorry, but no, it does not. The upgrade from 2.5.1 to 2.6 causes the following changes in the database:

    1. Two new roles are added for plugin handling.
    2. The activation keys are cleared (fixing a 2.5.1 issue).
    3. Two new options are added for XML-RPC and Atompub.

    Nothing is changed with regard to permalinks. If yours are broken, then something else on your site is screwed up somewhere. The fact that renaming your .htaccess made your site accessible again confirms this diagnosis.

  13. Anonymous
    Unregistered
    Posted 6 years ago #

    Well it is to be understood that this version of WP is a real source of nightmares: is a free software but is true that is now a world standard. Installing WP leads to a total mess. All my programmers and web designers in the worls are having severe and deep trouble. We are a international web agency. I am in Italy and today tried again with four different installation, no upgrade all new from scratch. All are looking messy and each has a different bunch of errors.

  14. jinge
    Member
    Posted 6 years ago #

    I say it again. We are many with problems:
    WHERE should I go for help. There is the same question in many topics now, I guess the moderator should start a topic named “problems with 2.6 permalinks”.

  15. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    jinge: You are in the right place for help. However, expecting instant help and instant answers is silly. If the problem was known, it would not be there.

    Be patient. Stop posting every 20 minutes. This is not a contest for who can complain the most.

    You'll get the answer when the answer is known and not before that.

    That said, this seems to be a Windows server specific issue. So one fix would be to switch to Linux/Apache.

  16. jinge
    Member
    Posted 6 years ago #

    Otto! Where can i download a 2.5.1 ??

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

  18. mikejandreau
    Member
    Posted 6 years ago #

    I'd suggest making your .htaccess writable by the server (777), then re-set your permalink settings.

    I upgraded all 17 sites I manage that use WordPress, to 2.6 this morning, without issue on any one of them.

    The new features are awesome. I love the "nagging - update your plugins!" number. Pretty cool stuff.

  19. Greg Rickaby
    Member
    Posted 6 years ago #

    OTTO, this is NOT a windows specific issue. I'm running linux, it's happening across all my wordpress sites with custom permalinks: /index.php/%postname%.html

    It works fine if I go to default...but once I move to the above structure it doesn't.

    I've tried deleting .htaccess, I've tried setting to default then going back to custom...nothing seems to work. Hope this helps.

    -Greg

  20. jinge
    Member
    Posted 6 years ago #

    My .htaccess is writable and I can’t login. When I rename it to a.htaccess I can login in my blog. I read some about Windows servers, but my ISP using Linuxservers.

    When I change permalinks to default it works like it should, but I can’t try that when my .htacess is not disabled, because I can´t login. If I try I will get the “Internal Server Error”.

    So: My 5800 blog posts in not reachable because the address is: http://Jinge.se/index.php/mynewpost.htm (example). That is Googles index of it, and I have some thousand hits via Google every day. No other link will work either, they will receive the 404-page.

    Off course my .htaccess is 777.

    My custom permalink is /index.php/%category%/%postname%.htm but now I have disabled it.

  21. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    @gregrickaby: Why are you using /index.php/whatever permalinks if you're running on linux/apache?

    The whole index.php thing in the permalink thing is specifically for IIS servers, which don't support mod_rewrite.

    In other words, I'm amazed that /index.php/%postname%.html ever actually worked for you in the first place on a Linux/Apache setup. It shouldn't.

  22. Greg Rickaby
    Member
    Posted 6 years ago #

    @Otto

    I'm running a shared server @ Hostgator.com:

    Linux: 2.6.24.7-grsec
    Apache: 1.3.41 (Unix)
    PHP: 5.2.6
    MySQL: 5.0.51a-community

    I've used /index.php/%postname%.html for well over a year now and I've never had a permalink issue.

    I've also tried setting .htaccess permissions to 777 and setting to default permalink, then going to custom. Still no luck.

    The reason why: I've tried several different variations of the permalink structure to create SEO friendly URLS... that was the way I could get it to work is by putting /index.php in front.

    Website: gregrickaby.com

  23. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    What is in your .htaccess file?

    Also, have you tried using the non-default permalinks *without* the "index.php" in them?

    It simply doesn't make any sense to have index.php in your permalinks on a linux/apache setup. Why do you have that? There's no reason for it.

  24. 7milesdown
    Member
    Posted 6 years ago #

    Could you explain Otto why the /index.php/postname would not be working now after this minor upgrade? I've been using this permalink structure for close to four years on my windows server with wordpress and this is actually the first time I've experienced this issue.

  25. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Could you explain Otto why the /index.php/postname would not be working now after this minor upgrade?

    If I knew that, then I'd tell you how to fix it. :)

    I'm just reporting what I'm seeing people complaining about.

  26. Greg Rickaby
    Member
    Posted 6 years ago #

    @ otto

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  27. 7milesdown
    Member
    Posted 6 years ago #

    Thanks Otto. Please keep us Window Users posted! I'll lay in wait!!

  28. Greg Rickaby
    Member
    Posted 6 years ago #

    UPDATE!

    By removing the /index.php from the custom structure...permalinks now work. That is fine, except the hundreds of indexed pages on Google/Yahoo/MSN :(

  29. Edde Beket
    Member
    Posted 6 years ago #

    @jinge: the problem lies in the apache config / .htaccess if removing the .htaccess file solves the problem. Apache gives this error of you're trying to make it do something it doesn't want to do (apache config) or doesn't understand (error in your file).

    Putting back an old version of wordpress won't help either: once you ran update.php the changes to the database are there to stay. Unless you restore a backup. I don't think running WP 2.5.1 files in combination with a WP 2.6 database will improve things.

    Try creating an empty .htaccess with the right permissions. Update your permalink structure and check if the file is updated correctly.
    (remove old .htaccess, type touch .htaccess and then chmod 777 .htaccess).

    I remember now I've had this error too: a lethal combination of customized WordPress permalinks and no .htaccess file to match.

  30. Edde Beket
    Member
    Posted 6 years ago #

    @gregrickaby: Those links to hundreds of indexed pages should work fine I'd guess. That's why they're called "permalinks".

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.